summaryrefslogtreecommitdiff
path: root/app-editors/xmlcopyeditor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
commit59c2499e0c9720169c9d5a02168c51c807a21467 (patch)
tree48c68a8a7e0094b2edaace12850e6c059bc3636b /app-editors/xmlcopyeditor
parenta25cc082a26782e5d39ded4559c91ff11bc3c299 (diff)
gentoo auto-resync : 14:05:2024 - 00:01:24
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/Manifest2
-rw-r--r--app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.1.0-libxml2-2.12.patch20
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0-r1.ebuild50
3 files changed, 72 insertions, 0 deletions
diff --git a/app-editors/xmlcopyeditor/Manifest b/app-editors/xmlcopyeditor/Manifest
index 1e750f8a8675..9f73c41fa956 100644
--- a/app-editors/xmlcopyeditor/Manifest
+++ b/app-editors/xmlcopyeditor/Manifest
@@ -1,3 +1,5 @@
+AUX xmlcopyeditor-1.3.1.0-libxml2-2.12.patch 462 BLAKE2B 7fb468a7d29f57073943d50eb08517209fc3d88bf6ccab40f77415c27204e88b2b1a9152ad9e6fb42f6e5aac11d005b7fca0c8cd00400ccdee1df5eec98aa392 SHA512 5a63d2d15b56da0ef4182d8a15f43b9c7a89a0d7a2700d03c3b03973c50ac4d38b9b2065610f9742361347a083e6e07211a39c6ff373fe6ede3b8288d0146515
DIST xmlcopyeditor-1.3.1.0.tar.gz 5273837 BLAKE2B e3174587defb1941f4d40d91eec101e7de3996b5faf81061f66cdc6b7d092637a273a9b4ed5a83e72c5b0fcfd5d12e80420cb6890d71a667f0440ab818098df8 SHA512 ea262e1ac6536b71e3328e695ae5825a9aff7db7a8024eedc1b3f568a75deda06f0aaff838438f91ba44de5280d6288dc8dc2d85f74f1eb638ecc01e60481be7
+EBUILD xmlcopyeditor-1.3.1.0-r1.ebuild 1042 BLAKE2B 5a39ed35feba0cedb971665226234a7ee7330dcd0ddab383c1b56675bf9d52e9e6e02e3cb460ebaeaa1f76a634f495ed546ceb8212ee44b67c2cd2d63b90460d SHA512 4299d85ae115de6c251c69edfb658682183f968d7ee18f5aa6e88e597501f58793ef04274f209eef4eafe05becce9ecc597266c1088c8a646e7a7a3f83f38b50
EBUILD xmlcopyeditor-1.3.1.0.ebuild 981 BLAKE2B c60b08d7437c12622599ddf51f321afb355ee79a2160711f0e94ed23d4ab7f0f1f5883e1abbab0e18a9c21ca4c19a6bf953b15333ddd6a42c1e92354366e91d9 SHA512 7cac432dfe43f0ccf1f82ad6ef5fb91bccdc0f7592487017e937317bcf14e3a7db9d766958f34aa093be8e19920a86d478a42d3bd45d32c825d273d5d47546ff
MISC metadata.xml 251 BLAKE2B beeccf7350e2e1c3c316ff8f50e8b237dc77b2cfc087205abceae07ec412ad01185adb8774f13404795020391457055ccc6055b41f1a87e774af210727cf3f27 SHA512 955dca0667fad24cef685b0ea3fd7d0d30310997a4f814d583d933903f443f0775a2e7662836134cc7555d754b5bbf1fc352d0bc939a3ff4af24d15c517f0f28
diff --git a/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.1.0-libxml2-2.12.patch b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.1.0-libxml2-2.12.patch
new file mode 100644
index 000000000000..c3036584524c
--- /dev/null
+++ b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.1.0-libxml2-2.12.patch
@@ -0,0 +1,20 @@
+--- a/src/wraplibxml.cpp
++++ b/src/wraplibxml.cpp
+@@ -706,7 +706,7 @@
+
+ wxString WrapLibxml::getLastError()
+ {
+- xmlErrorPtr err = xmlGetLastError();
++ const xmlError *err = xmlGetLastError();
+
+ if ( !err )
+ return nonParserError;
+@@ -722,7 +722,7 @@
+
+ std::pair<int, int> WrapLibxml::getErrorPosition()
+ {
+- xmlErrorPtr err = xmlGetLastError();
++ const xmlError *err = xmlGetLastError();
+ if ( !err )
+ return std::make_pair ( 1, 1 );
+
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0-r1.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0-r1.ebuild
new file mode 100644
index 000000000000..7c171ac605c7
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit autotools wxwidgets xdg
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="https://xml-copy-editor.sourceforge.io"
+SRC_URI="https://downloads.sourceforge.net/xml-copy-editor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc ~x86 ~amd64-linux ~x86-linux" # -ppc due SSE2 requirement
+IUSE="aqua nls"
+
+RDEPEND="
+ app-text/enchant:2
+ >=dev-libs/libxml2-2.12.5
+ dev-libs/libxslt
+ dev-libs/xerces-c[cpu_flags_x86_sse2,icu]
+ dev-libs/libpcre2
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${P}-libxml2-2.12.patch )
+
+src_prepare() {
+ default
+
+ # bug #440744
+ sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets unicode
+ econf \
+ --with-gtk=3.0 \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable nls)
+}