summaryrefslogtreecommitdiff
path: root/app-editors/xmlcopyeditor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/xmlcopyeditor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/Manifest3
-rw-r--r--app-editors/xmlcopyeditor/metadata.xml10
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild43
3 files changed, 56 insertions, 0 deletions
diff --git a/app-editors/xmlcopyeditor/Manifest b/app-editors/xmlcopyeditor/Manifest
new file mode 100644
index 000000000000..a9d5d6b395b5
--- /dev/null
+++ b/app-editors/xmlcopyeditor/Manifest
@@ -0,0 +1,3 @@
+DIST xmlcopyeditor-1.2.1.3.tar.gz 4266907 BLAKE2B 52e8c27a37edbcc0da46b52443f5b6754252a62f1abb7746e724270dd5cd9a2db4de60e68d495008ef55a18e9c25149825c9b26c5fd6e20d8e3937931de64e74 SHA512 1adda58bc262cd22898ba22eed3cad9f4a51f199e779172af2d51c5d7bf6dac072b9015b90906236de83d7acebe29d0aae6ae73998ec9d9b3c58b02f081e0b4d
+EBUILD xmlcopyeditor-1.2.1.3.ebuild 921 BLAKE2B 1011f90af104285a39642c5d8d04f8dcef32d7523f4fcd07f8c39b887aed86bd5547173aed2a700b528089df8b97e3bdc0f42f62d7ee00dfd927dfebc9418e76 SHA512 c226e815d601d6551bc97a85d731379fb627d64a49f0e8a6e3993b4667968604fa3882b7a94b75713f0ff4f417038f71ddd92a3f34e0c0abc824aa242cc0e3c2
+MISC metadata.xml 299 BLAKE2B d4eb8befeca3801e2b1c8762bc4fca6556be50259e1147ceb1f69ea9d952415e608c5c8bd117947cf1a67420ffa9a86dde85c1d1d3b388f59634764702b909e4 SHA512 8dd8d77282bf225c1d1f040808c10b766a361ac70d0c27a643d1c7a8654e2737570bd3f58238c907047decfa88ccb904ba2399d700fbbe04409c2269b89d9ef9
diff --git a/app-editors/xmlcopyeditor/metadata.xml b/app-editors/xmlcopyeditor/metadata.xml
new file mode 100644
index 000000000000..4c003c163801
--- /dev/null
+++ b/app-editors/xmlcopyeditor/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Fast, free, validating XML editor.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xml-copy-editor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild
new file mode 100644
index 000000000000..f8f58ca6770f
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+WX_GTK_VER="3.0"
+
+inherit autotools wxwidgets
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="http://xml-copy-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xml-copy-editor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="aqua nls"
+
+RDEPEND="
+ app-text/aspell
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xerces-c[icu]
+ dev-libs/libpcre
+ !aqua? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+ aqua? ( x11-libs/wxGTK:${WX_GTK_VER}[aqua] )"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/intltool"
+
+DOCS=( AUTHORS ChangeLog README NEWS )
+
+src_prepare() {
+ # bug #440744
+ sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
+ eautoreconf
+
+ need-wxwidgets unicode
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}