summaryrefslogtreecommitdiff
path: root/app-editors/yudit/yudit-3.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
commit51a01b0f2371b8dfc39f2747ecafd7d5f083ecb4 (patch)
tree55d5c62353eb98ea2809ea087e9fc4b215c53563 /app-editors/yudit/yudit-3.1.0-r1.ebuild
parent46de1a2f454a1465026d681f5dfe8db7dde5b126 (diff)
gentoo auto-resync : 21:11:2023 - 23:10:38
Diffstat (limited to 'app-editors/yudit/yudit-3.1.0-r1.ebuild')
-rw-r--r--app-editors/yudit/yudit-3.1.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-editors/yudit/yudit-3.1.0-r1.ebuild b/app-editors/yudit/yudit-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..b28086e41aeb
--- /dev/null
+++ b/app-editors/yudit/yudit-3.1.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Free (Y)unicode text editor for all unices"
+HOMEPAGE="https://www.yudit.org/"
+SRC_URI="https://yudit.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+DOCS=( {BUGS,CHANGELOG,NEWS,TODO}.TXT )
+
+src_prepare() {
+ default
+ # Don't strip binaries, let portage do that.
+ # Don't call ar / ranlib directly
+ sed -i \
+ -e "/^INSTALL_PROGRAM/s| -s||" \
+ -e "s|ar cr|$(tc-getAR) cr|g" \
+ -e "s|ranlib|$(tc-getRANLIB)|g" \
+ Makefile.conf.in || die "sed failed"
+}