summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 10:19:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 10:19:19 +0100
commit92ebda186167f9887d5f43803ced730b499dcf57 (patch)
treeee0e4261f26516d8b6bdaa4c330eee878d9ca136 /app-editors
parentd84be18029b166ee26fe5416098974a8d05b2983 (diff)
gentoo auto-resync : 08:07:2023 - 10:19:19
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin13903 -> 13906 bytes
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-45.0.ebuild100
-rw-r--r--app-editors/gedit/Manifest2
-rw-r--r--app-editors/gedit/gedit-45.0.ebuild87
5 files changed, 191 insertions, 0 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index 6b2336996e66..9fc9af98c3f1 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 97b05d3378ba..23a8c8f4bdb2 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,3 +1,5 @@
DIST gedit-plugins-44.1.tar.xz 913228 BLAKE2B a153b82da23f7838da9fa24b28687eae2fd0e4381693515f45e665fc6d9bc2715b37fa6bdac7a8a6ebd947ba0a3a70e5c12708bb14a053c9ad0384549e8ef4f6 SHA512 d5d767210b362747e4ba51b61b4d1c58bf5b37aa5f942cb9654f71c534d8bce2594ebc9004bed686627403fe1c3a6af84a45f4ce72af1f27fa7b644d11cdc9e2
+DIST gedit-plugins-45.0.tar.xz 902452 BLAKE2B 2569de052fee9401561e874a0387799c582fd69c177034595e9bb61c9ebd75fb6333b4bd7d1c8460d4bb13c5cb0c1ea8abeeaac1bf53f2279d4a920d71b5069e SHA512 41ada11d4cfc99d3f8edab46916490bfb6282c82bc35952331a5e920ffb8490c9ca543d459ed670390e4268bf2068b86382be4049443ce73cd4bb60b9a31b879
EBUILD gedit-plugins-44.1.ebuild 2587 BLAKE2B 89f009a541f6d10c06a8208b7521ac57c23675da04871d7f4b3396dce5527ef94ae7c8dba873d26a29fce038744163239f5fae985894638ac1ef7c03de9020f5 SHA512 62a9a0b4fc3e63dd50ceb089fba6629aa7b613da925982a96abe6773fb51267b4a8e53a75ff59323fc0ea52be31c3f786c57111dd91881a298b9e8913fe9d2be
+EBUILD gedit-plugins-45.0.ebuild 2449 BLAKE2B a90490a5770058f741dc08dc82fd231ac4a75db4a149d718cae1ee67ff2d36b6d6d222f6d8370acfbdc48e350e6fc352b62b9c5b49beb52c08f34de6c2c44c66 SHA512 04ac542fca66d5606fefce52d3a7d44af27bbff681650f59af2f1f86144cbac8f8a6ef202f3a7e447c6061e256900eeb4904bb62951425342f43a97a8d349ba1
MISC metadata.xml 596 BLAKE2B cf545e591c160fc584c5c2b1e3f5fa6a47922a958f981daa5c85f3f6c8f7eaed2a520d6265241998dfe211098f70c75a0fdfff033e55e892e5775b678ea9ef5b SHA512 0a3b9e748bc2d22ea16a694f8ebd6196d05e6652f552523bfe6fa60f1c69ab50110692cda7a59239c8f6946c06d3139a4225f1744e0dd40ccbdef3e8b396f692
diff --git a/app-editors/gedit-plugins/gedit-plugins-45.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-45.0.ebuild
new file mode 100644
index 000000000000..a8aad8084b13
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-45.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ThirdPartyPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-45.0
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ gui-libs/libgedit-gtksourceview:300
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ -Dplugin_drawspaces=true
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ -Dplugin_smartspaces=true
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index 843b2ed3016a..981e419f6bbd 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1,3 +1,5 @@
DIST gedit-44.2.tar.xz 2741932 BLAKE2B ef069084b0a11d86a081f10542ddfe39e9a6989dd0d7e5749af3f62267ea52c6885bf3a50065227307cca6062098c460b05da89f1cd2de0b8d2e6c9c81feb8ad SHA512 c9dd412a16d7d0ba17214164017948bd1184ee5f9c44475e9e02880c0597b2fd9840f9488df7262cb413baedf5e16ce49dd32410b02ed0f53cf4bc94d3e3a4c7
+DIST gedit-45.0.tar.xz 2756252 BLAKE2B 70f998e1df2d9dc8be9019c68c91ad5b3b5c66a922b9e2501d914dda9e460a315c1456b8d048ea8653e3f39e94b5c58ebcca524fe8d9beb30da6e49de88e0612 SHA512 5f9ea9df9fe2572127f97980a4f3fe96931dc4e9beea6f08c2e20777ca7dfd58569de0ca09c9b9e03ed0beb27c2bf277a910c50babf9c1d258b495d364d60cf5
EBUILD gedit-44.2.ebuild 1770 BLAKE2B d39fd4a51787a1b29bb369fdbde8e220aeb5e71ff9186e10321bb73ff96d1ef502207061ce7b3a00158413cead0bbc09aa43b14fab47fdfe5cc779a9ef7739ab SHA512 0f1b68c2233c8e4d644d9757b92263f7ec49171fc64b4da237c3bc3d5be7f4017124af5b3de609aafdffb7231630c78775b7c10681d411f320e810d4a6892284
+EBUILD gedit-45.0.ebuild 1726 BLAKE2B 15260a13666c25289b191fba592d4505153bf0ec0979de2d91bf027152c791492faddf3acc6c389cb5df9b9575a07f81018131dedf8eaf06b74fb096db971578 SHA512 af118b25c6f259e06c34f5727fab8b7527dcaa6d6c9f364917f7c7f594b7ef9d1b47b58e9c50cfe4e6433dec7a3c7e523ce8affe444b727dadeefea5c72fcf3e
MISC metadata.xml 346 BLAKE2B 59226b3220bd9b1770fad0f5acf3b1888a57a3496f9e0a6eb0eb09c12b7a5aa461961753dd8a5a6f01db1cdb97af5b28d6a8d1d632b60f499f86e0864e29264f SHA512 3e1d83ad67b85a681b85f8fece9d6c2c3eab2f2f726447230dc1f2399a21cba211d97e11d8c06d0d1b1803fafe67be4b32c04b39c5f8586a421c525624f6697d
diff --git a/app-editors/gedit/gedit-45.0.ebuild b/app-editors/gedit/gedit-45.0.ebuild
new file mode 100644
index 000000000000..a8db7e853cde
--- /dev/null
+++ b/app-editors/gedit/gedit-45.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+python gtk-doc"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=gui-libs/amtk-5.6:=
+ >=gui-libs/tepl-6.5.1:=
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=app-text/gspell-0.2.5:0=
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+
+ gui-libs/libgedit-gtksourceview:300
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+"
+BDEPEND="
+ $(vala_depend)
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ -Duser_documentation=true
+
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use python; then
+ python_optimize
+ python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}