summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
commitb6fa31c964a602f8461a77d5b83355e8750c12eb (patch)
tree323fa7af31640b3ea8bb57fa7a927713f3d64769 /app-editors
parent868fd5dc8aab84930cfaa5252b8be06b35552765 (diff)
gentoo auto-resync : 16:07:2024 - 12:27:58
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin13951 -> 13948 bytes
-rw-r--r--app-editors/gnome-text-editor/Manifest2
-rw-r--r--app-editors/gnome-text-editor/gnome-text-editor-46.3.ebuild57
-rw-r--r--app-editors/xemacs/Manifest10
-rw-r--r--app-editors/xemacs/xemacs-21.4.24-r10.ebuild7
-rw-r--r--app-editors/xemacs/xemacs-21.4.24-r9.ebuild5
-rw-r--r--app-editors/xemacs/xemacs-21.5.35-r2.ebuild7
-rw-r--r--app-editors/xemacs/xemacs-21.5.35.ebuild7
-rw-r--r--app-editors/xemacs/xemacs-21.5.9999.ebuild7
9 files changed, 74 insertions, 28 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index 75a291684f22..fa63d561e334 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/gnome-text-editor/Manifest b/app-editors/gnome-text-editor/Manifest
index 2025c171c546..bcb867c55474 100644
--- a/app-editors/gnome-text-editor/Manifest
+++ b/app-editors/gnome-text-editor/Manifest
@@ -1,3 +1,5 @@
DIST gnome-text-editor-45.3.tar.xz 618756 BLAKE2B 45a6a78a665f833b0fb2e179125224e1d3757390deee5845b750bbc13368cd9b0b8521b290e42a2c5be82e2e7d78bab5e3aad256d1c87eade22547696807a8ba SHA512 d9fbdbb0dfbb5d10dc1b817f9ebf114a63e20724c3c230da683c8b7f1332371acf869c723a7067dbdafb5b4df23529944b40e5ec212e52a5a3220ca725388c95
+DIST gnome-text-editor-46.3.tar.xz 654128 BLAKE2B 42a3b89bfe977cb2160c390a0391da1634ae4b2490aaf2ba8dc3230695d6064aa5c3aa03596e3f3e075fef50bf4ed5890d52acfe053fe2e98e238c9a839e58b1 SHA512 576b60e3f005cefd9930838d12173609cf7a0e9f6cb16b91be0e68a215c5c814df67c18c8adcf5083b5e1a3280149ed4b0aa1d830ab367aa76949a9ce81efea4
EBUILD gnome-text-editor-45.3.ebuild 1072 BLAKE2B e1562b655b253a1d4ce93a37a11af6a3682654d5c0da8738e67f7908ee6f3aef6d6be385430d2f673e424211578cebe4f24c446f771c97c7acbd749bee5a1e6e SHA512 512e455ad2d85d552c0cea41f5c6aff5b3b993dabfb15a0947a738a871c1bc0dd0f49860effac348038fce924889ba71a26dda72000c3fc94b079b7a0e30082c
+EBUILD gnome-text-editor-46.3.ebuild 1077 BLAKE2B 6e14aae43ed0e68147d952851051d0a15b381af5038b7dfad91cc2c5881056e7620207ab51afa605ca145682cb56c1771814a50b818799ef92014f6e7fd4c598 SHA512 251a4fee9a069d61eccfe15c633da8c8968f8de6ea858e1356f474d08eed27cdc710cfa2fd97aab084ebc15fed35164a8d8b9592bf40ceb3c16fa27920d9de79
MISC metadata.xml 358 BLAKE2B 908c67ba226a7e65b72a1cbaea99350f05fe9f904644c99b9c4e1e0c81f795c1420a0ca9cba1d56f59fb1b841151ffcf7d088add9f36a0e88314f7f52da94fcf SHA512 5862fb965119f76e19ed997e53e651778458604f1f9b69a1ee04db8eac52bdb6352da84ecb92555b31d3b8c62aa544c57c6040ed358af3beddd35fe356744d85
diff --git a/app-editors/gnome-text-editor/gnome-text-editor-46.3.ebuild b/app-editors/gnome-text-editor/gnome-text-editor-46.3.ebuild
new file mode 100644
index 000000000000..817ed3c09384
--- /dev/null
+++ b/app-editors/gnome-text-editor/gnome-text-editor-46.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple text editor for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-text-editor"
+S="${WORKDIR}/gnome-text-editor-${PV/_/.}"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="spell"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.73.0:2
+ >=gui-libs/gtk-4.12:4
+ >=gui-libs/gtksourceview-5.10.0:5
+ >=gui-libs/libadwaita-1.5_alpha:1
+ app-text/editorconfig-core-c
+ x11-libs/cairo
+ spell? (
+ >=app-text/enchant-2.2.0:2
+ dev-libs/icu:=
+ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.21
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature spell enchant)
+ -Dbugreport_url="https://bugs.gentoo.org"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/xemacs/Manifest b/app-editors/xemacs/Manifest
index 21f10a4c3969..e2dc0ad68f1a 100644
--- a/app-editors/xemacs/Manifest
+++ b/app-editors/xemacs/Manifest
@@ -11,9 +11,9 @@ AUX xemacs.desktop 1061 BLAKE2B 47941fc8b380e08aad13e44fc1899ee73ef502dbbf5d8be4
DIST NeXT_XEmacs.tar.gz 39571 BLAKE2B 7abf17627ec34e6b0d0edde444028c46dca6d703cfa208a8a1eaf30e2fc2543b953c9a9582c3d55bd5b37e746f45c03ebfc408a0d965606e45d5f4adb9148dea SHA512 611ddbbf5be3d2274e7f76be7f8200c6c7f3cba917efcc24e73685aa5f61c94237e6e48ce66f2d59ee4b74862e686f3ea7a29cf006717d5d0674db24d243d566
DIST xemacs-21.4.24.tar.gz 8543879 BLAKE2B d7e60e4e053a10bfc4591a5d691c849ef5e5436f6951c801f5a169592b160669d0f6b9dc8f10b6b79889a3210de977ed78a5cea826c02e425495364745ef9e10 SHA512 b7a88d5a4a9f74f74c2067ed60f7ea87ac8ccad5d9c2c1033ecf07f540250191f8fa5f9e6d23d9fedd0f2ab1eb5ea6c29a7665a310ec512d85e2e4f337447213
DIST xemacs-21.5.35.tar.gz 16403617 BLAKE2B efab8d3d984ec2223913b09ff1abc9f2df187fb5b8c2ccf99fcfc60c86369f4411cffd48b03532d53329bd5b3d3149271a445da4c0a3cd7bdc2834021b1297b3 SHA512 e592af6ffbb6f95299039de28f59ee770bf62f54a15b1358b9d1059ed25dcb410c01dcf6e88c1d2196d54f0c6902f309d709fe003accee82e516023fa4363019
-EBUILD xemacs-21.4.24-r10.ebuild 7210 BLAKE2B d4ba5640df0f01408a3fa3ab1f345a570c8d525a6a4df8ec8014527418d1b6e43e14813404c44d7882b8c274c620a232162c19194bc8e78c2157cd78cfa8f2ad SHA512 078425d7ca1706520fca3025dad14cd31e3f4d1161192f78945cd749b55dca2634791b180bae2cd5e0bec86020b6a18af920f56e75e63b1a5ad7de640259453a
-EBUILD xemacs-21.4.24-r9.ebuild 7113 BLAKE2B b0cff6b002ee49f80b289e810c7f46c6864ccc60e7064a27857df148246999cb7c892a04bbf7e4d3cc37d55e49eb44bbf5a79fdb3d16983bbb3c5f4a01418e72 SHA512 1bf2721acc322fd1db5291ba54e43d0892ac5a925e88d7a69cc055cb7819d3ce341aef9e0a722ce329bcbb18f7cbc4380731a52c016b691f8382e33d21b0659d
-EBUILD xemacs-21.5.35-r2.ebuild 7256 BLAKE2B da7336bf9b77d39f37f2fa36f3994ada84d576ecb433de26d7d51484d556aa22aeb45e450f29232ed659022e16526b9200959489ed6a1d47239737d42a1f85ef SHA512 c9798a12b04d93c103c1f0874c03eea9f602c34a51d6cb78903dd84ec21b8789b691087cfc16c0fa57162a7b992088f56c08958a8a027bd065e76252676cf1f0
-EBUILD xemacs-21.5.35.ebuild 7144 BLAKE2B b970e504f65f9b8309bb5024ea3a880f7f46e03836ee8bb71a3a31cfeece0ac57dbe4f56c43893c62c3b42c3423f2a95ceb78d2431fe7eec8fcf2bda0d982e35 SHA512 1383a53fa8f3985b28401209dfdfa61cc6c7e21d61aa40fd32c813f363b5a1427f044d80ccd993cf3431de09785602802a043f6e8e36e8bbabb588380d8c6105
-EBUILD xemacs-21.5.9999.ebuild 7209 BLAKE2B 85c4c3f69f6cb2bb9d760b590b963e85164058f12371bd89c9c60c7859d7b271118ff0fd315df863380222832f362dd9da06869e3e96ae94341998d8e0654243 SHA512 e9b0ab92ebe86b5d354eb2e6ab5d3a2c0a207390e713b5eae98bcc251a333e32dc901444318738e73271ccd0ad27bc71f5d3ca15db8fc56142586fd98649585f
+EBUILD xemacs-21.4.24-r10.ebuild 7079 BLAKE2B 1508018ad49998db617ea144f4e79fcc3b52a6d4242a3ed1ac02cf472b551787d9ffd1459d7bab40d712f267e8cd9ccded228e6843b23a5e036ef98d453d325a SHA512 20d10fe24d551e4918d3cef29b9ef3b305390dcbb40eb1e23c32817cbb68a34ef2bc635dc20c0cb11d77f6ff90b3d8662c37ccf6d32228a8765178b8dc286dc9
+EBUILD xemacs-21.4.24-r9.ebuild 7051 BLAKE2B 8b51971c51bb99f0db8ecc6ab2af016e8972eae33b55f8409d2cc64d3cf7eef3689945d7a28c3ba945dc0d9d71d20162cee5ed03aa18d515bfc363aa8039b893 SHA512 bf9d1d56cf79483933734191fa8ec3e0eb0bdd913724d61c8e31ef67f813e1af4c0f8856f138499ddd447e0c581a270e9168c84c038befa6ff403e5becf05db7
+EBUILD xemacs-21.5.35-r2.ebuild 7137 BLAKE2B bbd5461d878a08808502404b84a9a429ce93f9b34c577ef89858b9461c92558ddbc211e9c57dc6f478d1c2677fa8cd61d8f033010a704c65f8e937e2b066322e SHA512 c921c3355ca3972ef30a2ec18605b5caf06613b8f589ea101a8d25ab0a1f22b47972d5d43357e87d015fe32e157a88bf04f13e05292d5fe7b4a67c09b59cf6ca
+EBUILD xemacs-21.5.35.ebuild 7025 BLAKE2B 695f2221402c2461116746c81f07811929274b53892fe87f6200d2c93ba4f9209cbd77e702eb7ad922c8115a96ee8afffbd657d6698dc0b452aa854041a22bf6 SHA512 d4a51870a73d2c9dcbb73f69e3dcb982443442e0be66c0a35bd2c0730e8813b8ebd2dfcffdb68221d2f24d078f47d6fe7e593157a4b1cda32887f1c88259f206
+EBUILD xemacs-21.5.9999.ebuild 7090 BLAKE2B c2d613ddb7ec5801e1aea864b81ba0efb475d5ec310890b7ba2254ca307cb71024cfc038b736d215b38d63fe7012594771950991bd138c8f962eeefc90b12a86 SHA512 5d719acfee3b869e47df35ffebccb0c8d0fc760b5474ac9b533ac44709c0c6d02c05eb7af708befd1788dd9c7cbd807d9660911b9b30e0f16aead409714a168a
MISC metadata.xml 756 BLAKE2B 1237bb18a737c4473990bd73a4a1fdd5788c743867b1f7c6d963f6acd21a7133fbe5b1c0921556a5152ab7f3116e635a6c6087dad15b5d2430a2d742c63a1a05 SHA512 65c0a9a02a9d11bde55cae161344803177203f4868f508c970d87fc7ea7b4f552f63d2e70ad2b1829efb8ff2ca641e1717672976f681ec56ad51dec2eebc8464
diff --git a/app-editors/xemacs/xemacs-21.4.24-r10.ebuild b/app-editors/xemacs/xemacs-21.4.24-r10.ebuild
index 7d1252abe2f3..5484370c0dff 100644
--- a/app-editors/xemacs/xemacs-21.4.24-r10.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.24-r10.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="eolconv gif gpm pop postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn xim athena neXt Xaw3d gdbm berkdb"
+IUSE="eolconv gif gpm pop postgres ldap xface nas dnd X jpeg tiff png mule motif xim athena neXt Xaw3d gdbm berkdb"
X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
@@ -41,7 +41,6 @@ RDEPEND="
tiff? ( media-libs/tiff:= )
png? ( >=media-libs/libpng-1.2:0 )
jpeg? ( media-libs/libjpeg-turbo:= )
- !amd64? ( freewnn? ( app-i18n/freewnn ) )
>=sys-libs/ncurses-5.2:=
>=app-eselect/eselect-emacs-1.15"
@@ -146,7 +145,7 @@ src_configure() {
myconf="${myconf} --with-xim=no"
fi
- myconf="${myconf} $(use_with freewnn wnn )"
+ myconf="${myconf} --without-wnn"
fi
# This determines the type of sounds we are playing
@@ -175,8 +174,6 @@ src_configure() {
# see bug 576512
append-cflags -fgnu89-inline
- use freewnn && append-cppflags "-I. -I${ESYSROOT}/usr/include/wnn"
-
# Don't use econf because it uses options which this configure
# script does not understand (like --host).
./configure ${myconf} ${EXTRA_ECONF} \
diff --git a/app-editors/xemacs/xemacs-21.4.24-r9.ebuild b/app-editors/xemacs/xemacs-21.4.24-r9.ebuild
index ce257c1934e4..fd04e149f938 100644
--- a/app-editors/xemacs/xemacs-21.4.24-r9.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.24-r9.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 arm64 ~hppa ppc ppc64 sparc x86"
-IUSE="eolconv gif gpm pop postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn xim athena neXt Xaw3d gdbm berkdb"
+IUSE="eolconv gif gpm pop postgres ldap xface nas dnd X jpeg tiff png mule motif xim athena neXt Xaw3d gdbm berkdb"
X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
@@ -41,7 +41,6 @@ RDEPEND="
tiff? ( media-libs/tiff:= )
png? ( >=media-libs/libpng-1.2:0 )
jpeg? ( media-libs/libjpeg-turbo:= )
- !amd64? ( freewnn? ( app-i18n/freewnn ) )
>=sys-libs/ncurses-5.2:=
>=app-eselect/eselect-emacs-1.15"
@@ -146,7 +145,7 @@ src_configure() {
myconf="${myconf} --with-xim=no"
fi
- myconf="${myconf} $(use_with freewnn wnn )"
+ myconf="${myconf} --without-wnn"
fi
# This determines the type of sounds we are playing
diff --git a/app-editors/xemacs/xemacs-21.5.35-r2.ebuild b/app-editors/xemacs/xemacs-21.5.35-r2.ebuild
index e72137718c55..16f96c54d3de 100644
--- a/app-editors/xemacs/xemacs-21.5.35-r2.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.35-r2.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://ftp.xemacs.org/pub/xemacs/xemacs-$(ver_cut 1-2)/${P}.tar.gz
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="alsa debug gif gpm pop postgres ldap xface nas dnd X jpeg tiff png motif freewnn xft xim athena neXt Xaw3d gdbm berkdb +bignum"
+IUSE="alsa debug gif gpm pop postgres ldap xface nas dnd X jpeg tiff png motif xft xim athena neXt Xaw3d gdbm berkdb +bignum"
X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
@@ -43,7 +43,6 @@ RDEPEND="
tiff? ( media-libs/tiff:= )
png? ( >=media-libs/libpng-1.2:0 )
jpeg? ( media-libs/libjpeg-turbo:= )
- freewnn? ( app-i18n/freewnn )
>=sys-libs/ncurses-5.2:=
>=app-eselect/eselect-emacs-1.15
bignum? ( dev-libs/openssl )"
@@ -137,7 +136,7 @@ src_configure() {
myconf="${myconf} --with-xim=no"
fi
- myconf="${myconf} $(use_with freewnn wnn )"
+ myconf="${myconf} --without-wnn"
# This determines the type of sounds we are playing
local soundconf="native"
@@ -168,8 +167,6 @@ src_configure() {
use bignum && myconf="${myconf} --with-bignum=openssl" ||
myconf="${myconf} --with-bignum=no"
- use freewnn && append-cppflags "-I. -I${ESYSROOT}/usr/include/wnn"
-
econf ${myconf} \
$(use_with gif ) \
$(use_with gpm ) \
diff --git a/app-editors/xemacs/xemacs-21.5.35.ebuild b/app-editors/xemacs/xemacs-21.5.35.ebuild
index 81c8ab501cb5..aff1f6acbb7c 100644
--- a/app-editors/xemacs/xemacs-21.5.35.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.35.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://ftp.xemacs.org/pub/xemacs/xemacs-$(ver_cut 1-2)/${P}.tar.gz
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~alpha amd64 arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
-IUSE="alsa debug gif gpm pop postgres ldap xface nas dnd X jpeg tiff png motif freewnn xft xim athena neXt Xaw3d gdbm berkdb +bignum"
+IUSE="alsa debug gif gpm pop postgres ldap xface nas dnd X jpeg tiff png motif xft xim athena neXt Xaw3d gdbm berkdb +bignum"
X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
@@ -43,7 +43,6 @@ RDEPEND="
tiff? ( media-libs/tiff:= )
png? ( >=media-libs/libpng-1.2:0 )
jpeg? ( media-libs/libjpeg-turbo:= )
- freewnn? ( app-i18n/freewnn )
>=sys-libs/ncurses-5.2:=
>=app-eselect/eselect-emacs-1.15
bignum? ( dev-libs/openssl )"
@@ -136,7 +135,7 @@ src_configure() {
myconf="${myconf} --with-xim=no"
fi
- myconf="${myconf} $(use_with freewnn wnn )"
+ myconf="${myconf} --without-wnn"
# This determines the type of sounds we are playing
local soundconf="native"
@@ -162,8 +161,6 @@ src_configure() {
use bignum && myconf="${myconf} --with-bignum=openssl" ||
myconf="${myconf} --with-bignum=no"
- use freewnn && append-cppflags "-I. -I${ESYSROOT}/usr/include/wnn"
-
econf ${myconf} \
$(use_with gif ) \
$(use_with gpm ) \
diff --git a/app-editors/xemacs/xemacs-21.5.9999.ebuild b/app-editors/xemacs/xemacs-21.5.9999.ebuild
index 179f1be38534..9f275d6c2c18 100644
--- a/app-editors/xemacs/xemacs-21.5.9999.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.9999.ebuild
@@ -17,7 +17,7 @@ EHG_REPO_URI="https://foss.heptapod.net/xemacs/xemacs"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="alsa debug gif gpm pop postgres ldap xface nas dnd X jpeg tiff png motif freewnn xft xim athena neXt Xaw3d gdbm berkdb +bignum"
+IUSE="alsa debug gif gpm pop postgres ldap xface nas dnd X jpeg tiff png motif xft xim athena neXt Xaw3d gdbm berkdb +bignum"
X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
@@ -43,7 +43,6 @@ RDEPEND="
tiff? ( media-libs/tiff:= )
png? ( >=media-libs/libpng-1.2:0 )
jpeg? ( media-libs/libjpeg-turbo:= )
- freewnn? ( app-i18n/freewnn )
>=sys-libs/ncurses-5.2:=
>=app-eselect/eselect-emacs-1.15
bignum? ( dev-libs/openssl )"
@@ -138,7 +137,7 @@ src_configure() {
myconf="${myconf} --with-xim=no"
fi
- myconf="${myconf} $(use_with freewnn wnn )"
+ myconf="${myconf} --without-wnn"
# This determines the type of sounds we are playing
local soundconf="native"
@@ -169,8 +168,6 @@ src_configure() {
use bignum && myconf="${myconf} --with-bignum=openssl" ||
myconf="${myconf} --with-bignum=no"
- use freewnn && append-cppflags "-I. -I${ESYSROOT}/usr/include/wnn"
-
econf ${myconf} \
$(use_with gif ) \
$(use_with gpm ) \