summaryrefslogtreecommitdiff
path: root/app-emacs/auto-complete
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/auto-complete
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/auto-complete')
-rw-r--r--app-emacs/auto-complete/Manifest4
-rw-r--r--app-emacs/auto-complete/auto-complete-1.3.1.ebuild33
-rw-r--r--app-emacs/auto-complete/files/50auto-complete-gentoo.el3
-rw-r--r--app-emacs/auto-complete/metadata.xml12
4 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/auto-complete/Manifest b/app-emacs/auto-complete/Manifest
new file mode 100644
index 000000000000..a8a333847d1f
--- /dev/null
+++ b/app-emacs/auto-complete/Manifest
@@ -0,0 +1,4 @@
+AUX 50auto-complete-gentoo.el 157 BLAKE2B abf93b1a7c9bb3d2ebabacf66c40e3177fc611330f902ef446ae31ed7f140c8fbbc68f35b40b84e83a002fe83e998d393ea4c38ed5e251f6edae08dc0adacb27 SHA512 40d03bf5dbd718aeab5d5f1ad0a15b24bebc86f641570611facf79f58f4a370da2ef1a5ca6edbbcec35d2530bdf5bf097c19c7f56c0c8f81eefa0df1a8dc01b0
+DIST auto-complete-1.3.1.tar.bz2 155081 BLAKE2B 7ceedcececcd80b7d8207cb2ff88f2bbfeee892d56a96f44c6929323ca974206b6d977830a8593ba9f7c87ba86914bf9a0771f5e11a284d7bb42fdd9e9985b48 SHA512 5b82120f8faf1ee4ff139f4fbacb894fa0bf617b9a0aaebb5a0d672a6f90cb01bc35f0c99cebe2bef55cb7a6af6ce03936a7226c89e3c79248aacf4ae554fb7b
+EBUILD auto-complete-1.3.1.ebuild 697 BLAKE2B e715d59eb08903bcee5f92b8c3ae3bb8bbc2da2a8d4327ee401465338c46945e43defcf6149a6c16ab64b0e159a99f48a29c12dd4ba7158b98fa1e491431480e SHA512 f2820f4509f6af12c131c2cfacf7306a9eb377105c5f911b2c13ca86a4de84c65df0853ec9f2391f93d75be1122e1d53e2cc26b35488b2c633735cafaaf78305
+MISC metadata.xml 363 BLAKE2B 138b2cad3896e75b8f3cb4a38d22c49aabf379cef5f5e006df38ae86bf16bfe60e62536b5af18279554ec93a596a0b483ac3f2956cd7a66e3ff980a80a2eb155 SHA512 ce1f5579523af633640669429599b8bed17f1f32c650a577b2b477d82949a8afb592712b254fb40bdc7613322781e3f47882dd851a6124013063048d2d8b7c53
diff --git a/app-emacs/auto-complete/auto-complete-1.3.1.ebuild b/app-emacs/auto-complete/auto-complete-1.3.1.ebuild
new file mode 100644
index 000000000000..ffc316f47988
--- /dev/null
+++ b/app-emacs/auto-complete/auto-complete-1.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Auto-complete package"
+HOMEPAGE="http://cx4a.org/software/auto-complete/
+ https://github.com/m2ym/auto-complete/"
+SRC_URI="http://cx4a.org/pub/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="l10n_ja"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ # install dictionaries
+ insinto "${SITEETC}/${PN}"
+ doins -r dict
+
+ dodoc README.txt TODO.txt etc/test.txt
+ cd doc
+ dodoc index.txt manual.txt demo.txt changes.txt *.png
+ if use l10n_ja; then
+ dodoc index.ja.txt manual.ja.txt changes.ja.txt
+ fi
+}
diff --git a/app-emacs/auto-complete/files/50auto-complete-gentoo.el b/app-emacs/auto-complete/files/50auto-complete-gentoo.el
new file mode 100644
index 000000000000..c380d11b3a1e
--- /dev/null
+++ b/app-emacs/auto-complete/files/50auto-complete-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'auto-complete-mode "auto-complete" "AutoComplete mode" t)
+(setq ac-dictionary-directories "@SITEETC@/dict")
diff --git a/app-emacs/auto-complete/metadata.xml b/app-emacs/auto-complete/metadata.xml
new file mode 100644
index 000000000000..c09261b152ee
--- /dev/null
+++ b/app-emacs/auto-complete/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">m2ym/auto-complete</remote-id>
+</upstream>
+</pkgmetadata>