summaryrefslogtreecommitdiff
path: root/app-emacs/avy-embark-collect/avy-embark-collect-0.22.1_p20230630.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-07 04:15:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-07 04:15:42 +0100
commit0735b7c70f35339a20b45aee2a0a0ad80d118550 (patch)
tree2701d176f865b77b7ebd8ee7fa1445ee04d13533 /app-emacs/avy-embark-collect/avy-embark-collect-0.22.1_p20230630.ebuild
parent37707aeea7000a1e20d52db99ca6a70674ce89f3 (diff)
gentoo auto-resync : 07:07:2023 - 04:15:41
Diffstat (limited to 'app-emacs/avy-embark-collect/avy-embark-collect-0.22.1_p20230630.ebuild')
-rw-r--r--app-emacs/avy-embark-collect/avy-embark-collect-0.22.1_p20230630.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/avy-embark-collect/avy-embark-collect-0.22.1_p20230630.ebuild b/app-emacs/avy-embark-collect/avy-embark-collect-0.22.1_p20230630.ebuild
new file mode 100644
index 000000000000..a5b5c28a6dcb
--- /dev/null
+++ b/app-emacs/avy-embark-collect/avy-embark-collect-0.22.1_p20230630.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Use avy to jump to Embark Collect entries"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oantolin/embark.git"
+else
+ [[ ${PV} == *_p20230630 ]] && COMMIT=f2dcfe4d797a3ab66bb603d5cf441ae1172a672d
+ SRC_URI="https://github.com/oantolin/embark/archive/${COMMIT}.tar.gz
+ -> embark-${PV}.tar.gz"
+ S="${WORKDIR}"/embark-${COMMIT}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/avy
+ app-emacs/embark
+"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="embark-consult.el embark-org.el embark.el"
+
+SITEFILE="50${PN}-gentoo.el"