summaryrefslogtreecommitdiff
path: root/app-emacs/bind-chord/bind-chord-2.4.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/bind-chord/bind-chord-2.4.1-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/bind-chord/bind-chord-2.4.1-r1.ebuild')
-rw-r--r--app-emacs/bind-chord/bind-chord-2.4.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/bind-chord/bind-chord-2.4.1-r1.ebuild b/app-emacs/bind-chord/bind-chord-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..f37f89180fc6
--- /dev/null
+++ b/app-emacs/bind-chord/bind-chord-2.4.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Key-chord binding helper for use-package-chords"
+HOMEPAGE="https://github.com/jwiegley/use-package/"
+SRC_URI="https://github.com/jwiegley/use-package/archive/${PV}.tar.gz
+ -> use-package-${PV}.tar.gz"
+S="${WORKDIR}"/use-package-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/bind-key
+ app-emacs/key-chord
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ elisp-install ${PN} ${PN}.el{,c}
+}