summaryrefslogtreecommitdiff
path: root/app-emacs/buttercup/buttercup-1.33.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
commit145b1805c3986974378af5c60767504ecc9ed280 (patch)
tree28dbd5be73a5af5dd20d4ea81d293394d975c9e0 /app-emacs/buttercup/buttercup-1.33.ebuild
parent627302fc2f41a621644260ffa3f50e06ea5edd60 (diff)
gentoo auto-resync : 10:12:2023 - 23:14:40
Diffstat (limited to 'app-emacs/buttercup/buttercup-1.33.ebuild')
-rw-r--r--app-emacs/buttercup/buttercup-1.33.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/buttercup/buttercup-1.33.ebuild b/app-emacs/buttercup/buttercup-1.33.ebuild
new file mode 100644
index 000000000000..c7925cd2ca34
--- /dev/null
+++ b/app-emacs/buttercup/buttercup-1.33.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Behaviour-driven Elisp testing"
+HOMEPAGE="https://github.com/jorgenschaefer/emacs-buttercup"
+SRC_URI="https://github.com/jorgenschaefer/emacs-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DOCS=( docs/{running,writing}-tests.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l buttercup \
+ -f buttercup-run-discover || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+ dobin bin/${PN}
+}