summaryrefslogtreecommitdiff
path: root/app-emacs/citar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
commitf1cd8f3514f8b9fbc1cc9cfe0dd08a8cb258e87a (patch)
treee16b2f573ffa54d21accbf0dfc3647b47b0578c8 /app-emacs/citar
parente9c5cd3a9230f2f3f5980a5ca0c4ec20c099c7ed (diff)
gentoo auto-resync : 10:08:2022 - 20:18:34
Diffstat (limited to 'app-emacs/citar')
-rw-r--r--app-emacs/citar/Manifest4
-rw-r--r--app-emacs/citar/citar-1.0.ebuild43
-rw-r--r--app-emacs/citar/files/50citar-gentoo.el2
-rw-r--r--app-emacs/citar/metadata.xml23
4 files changed, 72 insertions, 0 deletions
diff --git a/app-emacs/citar/Manifest b/app-emacs/citar/Manifest
new file mode 100644
index 000000000000..49ff9b18b3ba
--- /dev/null
+++ b/app-emacs/citar/Manifest
@@ -0,0 +1,4 @@
+AUX 50citar-gentoo.el 69 BLAKE2B 4852ed7422e341e92f938dceedc3d6f0d0fdf8f955ef93021286d9d10e7c3a5d726175e2e79d34ca67f6815d7d6e0445ca2c9a80a2a6690daf4bda49d9972f96 SHA512 0afe62329cd2dc6ea548bbc28aa3c7fea86fb2a20febc91528ba994c77edf08fd72dcf1a0c417dcd4db75b4a6b8e237ade2257130ff3887499377b8f77fefc46
+DIST citar-1.0.tar.gz 1339812 BLAKE2B 2093cc820199219ec70f99a746c630f2b8e6b4d464b1457d7b7db1c5c953138e7dd5ac55e21b13e7417dd0a764b6f1caaf400af353ecce9fb7e1bc578f570b0d SHA512 7f02a4e41a927c2c7c625189fa38caea8f0fc5616dd3487a93f71a373d1e4a124dd1cc520778a1ff2fa6dd7c3b619b539e3b0e47cb9caf7edd16e27e9d739585
+EBUILD citar-1.0.ebuild 979 BLAKE2B 8b40e7b2c88ea5b739db50ffd588be12720330a89c84a11c2e0092fab7c08bc8c411e04e476df97867a7fd0ba59bee8829519a99fc2856c70ecbca7da8c2a29a SHA512 192a72c0a645dde0fabd681769f1dfa1eb9cf5f2cc91a996c7f52f837ef014543b2d2f299b35dcf3ee5c696da66f3fa63fc84caa64692d599293f95b67424bf0
+MISC metadata.xml 1034 BLAKE2B 10d658566f58e3a91deab1c4d2035bcd25ee216777aa105b1e8c8853ab103add779f0f439e706496b2468a3fcb8490320ccb454d90c2e70b5b8bbe9f218773e4 SHA512 4b81115dfccc471987c63876c0b282875fe95c5738f69dfdf7a6300c37998102f2fdda829d14938871bd857fbb5d145e6c62b5b4be40b532f46245256d0be259
diff --git a/app-emacs/citar/citar-1.0.ebuild b/app-emacs/citar/citar-1.0.ebuild
new file mode 100644
index 000000000000..0f6a51de1eb0
--- /dev/null
+++ b/app-emacs/citar/citar-1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs package to quickly find and act on bibliographic references"
+HOMEPAGE="https://github.com/emacs-citar/citar/"
+SRC_URI="https://github.com/emacs-citar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-emacs/citeproc-el
+ app-emacs/parsebib
+"
+BDEPEND="${RDEPEND}"
+
+# Embark integration has it's own package on MELPA, and it is probably better
+# to split them. https://melpa.org/#/citar-embark
+ELISP_REMOVE="citar-embark.el"
+
+DOCS=( CHANGELOG.org CONTRIBUTING.org README.org images )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l test/citar-file-test.el \
+ -l test/citar-format-test.el \
+ -l test/citar-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}
diff --git a/app-emacs/citar/files/50citar-gentoo.el b/app-emacs/citar/files/50citar-gentoo.el
new file mode 100644
index 000000000000..6243866c44c2
--- /dev/null
+++ b/app-emacs/citar/files/50citar-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "citar-autoloads" nil t)
diff --git a/app-emacs/citar/metadata.xml b/app-emacs/citar/metadata.xml
new file mode 100644
index 000000000000..2ba5ec6831b5
--- /dev/null
+++ b/app-emacs/citar/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Emacs package to quickly find and act on bibliographic references, and edit
+ org, markdown, and latex academic documents. This package provides a
+ completing-read front-end to browse and act on BibTeX, BibLaTeX, and CSL
+ JSON bibliographic data, and LaTeX, markdown, and org-cite editing support.
+ When used with vertico, embark, and marginalia, it provides similar
+ functionality to helm-bibtex and ivy-bibtex: quick filtering and selecting
+ of bibliographic entries from the minibuffer, and the option to run
+ different commands against them.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/emacs-citar/citar/issues/</bugs-to>
+ <remote-id type="github">emacs-citar/citar</remote-id>
+ </upstream>
+</pkgmetadata>