summaryrefslogtreecommitdiff
path: root/app-emacs/commander
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/commander
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/commander')
-rw-r--r--app-emacs/commander/Manifest4
-rw-r--r--app-emacs/commander/commander-0.7.0-r1.ebuild41
-rw-r--r--app-emacs/commander/files/50commander-gentoo.el1
-rw-r--r--app-emacs/commander/metadata.xml13
4 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/commander/Manifest b/app-emacs/commander/Manifest
new file mode 100644
index 000000000000..49ae838da1bc
--- /dev/null
+++ b/app-emacs/commander/Manifest
@@ -0,0 +1,4 @@
+AUX 50commander-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST commander-0.7.0.tar.gz 37120 BLAKE2B 61e7262f7909d866f3890854cc695d1d8769ea54fa2a983d72a3e5b61217f1e898036026f71d8ae0d46e8d45af0b9e0e52c2f88d4f647dd50454877b9abd2946 SHA512 10d25d931f1faf88747c397594becc3832dfb56de7440ada2cd40e0329b0ca984eda77c62290329510ab87b53ac273e5d36e7acd628ff68ee0e981ccd9497d10
+EBUILD commander-0.7.0-r1.ebuild 736 BLAKE2B 2111f5f9c73d306a601a609485df5224e5039675cf4cffaaac26d817ff6acd3d662a0ba06308c4c58dfdfad5fa23fbcefc9f45bf62eea3fb6960e4615f560683 SHA512 883da90cdfbe60eb7c8f0d99c6647ead65fbc5ab90aa14b0389ac294f90a712e397773043a47c0cfc5a95f70ae0e40bea3401abe3770b9b62f53a0c2aef2e5ba
+MISC metadata.xml 427 BLAKE2B c2880e0565e76e17608bbb9c604f68d456fa50507619778328e0a7d440de8379ef2b0f6227363c54212fc69216eeaa3fd820cf65afb0fdfd4b196185f421597f SHA512 c0015a2295bbea6a9df5e0e7e25f4f8871c8fde5e359cedc8e0de7ce112e82fce2278ab33c040a93c54722e2aab100cbd3477bb507f33386faa96031928b6543
diff --git a/app-emacs/commander/commander-0.7.0-r1.ebuild b/app-emacs/commander/commander-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..f7609e0868c7
--- /dev/null
+++ b/app-emacs/commander/commander-0.7.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs command line parser"
+HOMEPAGE="https://github.com/rejeep/commander.el/"
+SRC_URI="https://github.com/rejeep/${PN}.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ecukes
+ app-emacs/el-mock
+ app-emacs/ert-runner
+ app-emacs/espuds
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner || die
+ ecukes --debug --reporter spec --script features || die
+}
diff --git a/app-emacs/commander/files/50commander-gentoo.el b/app-emacs/commander/files/50commander-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/commander/files/50commander-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/commander/metadata.xml b/app-emacs/commander/metadata.xml
new file mode 100644
index 000000000000..6041ed51028f
--- /dev/null
+++ b/app-emacs/commander/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/rejeep/commander.el/issues/</bugs-to>
+ <remote-id type="github">rejeep/commander.el</remote-id>
+ </upstream>
+</pkgmetadata>