summaryrefslogtreecommitdiff
path: root/app-emacs/counsel/counsel-0.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 17:39:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 17:39:25 +0100
commit0d39cf7bd8aae36b5d8eb4272a42dc6919216e34 (patch)
treea693bda4655d339b219f18fa48d970444858c94d /app-emacs/counsel/counsel-0.14.0.ebuild
parent9d8d34d0eedfd7319f905092519980bf1b4ce3e5 (diff)
gentoo auto-resync : 11:04:2023 - 17:39:25
Diffstat (limited to 'app-emacs/counsel/counsel-0.14.0.ebuild')
-rw-r--r--app-emacs/counsel/counsel-0.14.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/counsel/counsel-0.14.0.ebuild b/app-emacs/counsel/counsel-0.14.0.ebuild
new file mode 100644
index 000000000000..4b056723c545
--- /dev/null
+++ b/app-emacs/counsel/counsel-0.14.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Versions of common Emacs commands customized to make the best use of ivy"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.tar.gz"
+S="${WORKDIR}"/swiper-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in app-emacs/ivy
+
+RDEPEND="
+ >=app-emacs/ivy-${PV}
+ >=app-emacs/swiper-${PV}
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}