summaryrefslogtreecommitdiff
path: root/app-emacs/counsel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
commit4b1be5ef874aaeb61a2116048e0c2312e53f8c69 (patch)
treee2f0118b102bf7e7ad852582d410adb43f13b035 /app-emacs/counsel
parent4418da21bd05d610a3450f4aa75481785ca372a0 (diff)
gentoo auto-resync : 28:02:2025 - 19:27:52
Diffstat (limited to 'app-emacs/counsel')
-rw-r--r--app-emacs/counsel/Manifest2
-rw-r--r--app-emacs/counsel/counsel-0.15.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/counsel/Manifest b/app-emacs/counsel/Manifest
index 7360191640fd..bf0e9d8b8387 100644
--- a/app-emacs/counsel/Manifest
+++ b/app-emacs/counsel/Manifest
@@ -1,4 +1,6 @@
AUX 50counsel-gentoo.el 110 BLAKE2B 223dc0b9991156d3494e9e954624ec060515231f5ca979345864dad802ccaaaff02eb43e13a7af5eed581e4189005493bbda3d849ef8c7b9b877993f9e096a78 SHA512 be21f737978b64065af31df15320ddb06f255a258d05d75227f4762a35a6eb86b0012561a40f7f72f154af58c0ce240c50958a8020d3a0dc5054c6b5834b80c8
DIST swiper-0.14.2.tar.gz 250059 BLAKE2B 8a5437726c729398a689266d138f271f5f7329f9c58613c4e0cfabd16b99421035c4b522d0ea4c60c0369362cb076bcae05ff4155d33d186172fd0ac2258495d SHA512 e125a3747abc4e6ecc98f539cf5dde11851d6c8a58b8988e165300bce7822fc91257cae09c973bd43435fb08dc24af9a1bd4b3e51083b45654b1605d80973d74
+DIST swiper-0.15.0.gh.tar.gz 255140 BLAKE2B becd63e0c291eccaf6b9520b0b50201aecbc5245128285384780ad8124294c3f7103ae7197db766b69c2ee3f32b5039fea47bd1303fab90d15ef8c109388e533 SHA512 c37c7482aae8d595181dab11ae613c52ae917c909033e3534ac5c78d090d1f67e2f36917a76b0dd4cfc8a339ed76c2480a7ca26a033b8be69dc3a128a0ccf00f
EBUILD counsel-0.14.2.ebuild 768 BLAKE2B e9ec9d5be3fcefb8d76b2a30a51586be3c97eeb180ff850383e6e778452964d5a2442fa76ceb00f1be5222d780af7f384f91346fe614b6e28ced2d5082b24908 SHA512 10c946c5738a21480032572f14e8248a52c4ecbc4a9b5ea11700d8f0c1f91fa250a5d1a3da87218254926307980ec4457feba0ab5f9d46018e3172c9c3e2ed31
+EBUILD counsel-0.15.0.ebuild 918 BLAKE2B a693dd5ca9288495d0c62ea75ea33da6af93a2a673606667603bbab15dd9f077f7f50f0258863decaffdaebd7376740ee744ae2180834d4b3b7a27ccc41716cb SHA512 78f3fe36a0a07832709e5446aecc4a805f23fb6a4caca0c4e59eef3b0c4ce0c70af5064f854c46b458d5473fdf5db7f88316b378889d7a1b69aefbec9c5017b2
MISC metadata.xml 597 BLAKE2B 596d80d3c2fd29ce075b056874d9f6357dfb0ae03442cf2dde601a799a1f531fbcd6c13be5d4f3dcbd2c0f842e88db2835ce796c5e420e2042760c0c14ea826e SHA512 a798bc29542e614a8f09e5f080fa2e67268f787c1bf7e399ac851d7d1c8c14843a82ec35578e7036b3897f13b0bc4286ce1d2b2c31632daf1331670e0abe46ee
diff --git a/app-emacs/counsel/counsel-0.15.0.ebuild b/app-emacs/counsel/counsel-0.15.0.ebuild
new file mode 100644
index 000000000000..f638c6e986cd
--- /dev/null
+++ b/app-emacs/counsel/counsel-0.15.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Versions of common Emacs commands customized to make the best use of ivy"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/abo-abo/swiper"
+else
+ SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.gh.tar.gz"
+ S="${WORKDIR}/swiper-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in "app-emacs/ivy".
+
+RDEPEND="
+ >=app-emacs/ivy-${PV}
+ >=app-emacs/swiper-${PV}
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile "${PN}.el"
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ elisp-install "${PN}" "${PN}.el"{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}