summaryrefslogtreecommitdiff
path: root/app-emacs/crux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 06:08:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 06:08:15 +0000
commit083bdfbef9bc532b72cf116591025916eebaf676 (patch)
tree04da8a6f58a6ef6f05ebafc0a86b3a27c00ba283 /app-emacs/crux
parente84469d1a99031578172f7c064945ba5114c5263 (diff)
gentoo auto-resync : 05:01:2023 - 06:08:15
Diffstat (limited to 'app-emacs/crux')
-rw-r--r--app-emacs/crux/Manifest4
-rw-r--r--app-emacs/crux/crux-0.4.0.ebuild23
-rw-r--r--app-emacs/crux/files/50crux-gentoo.el2
-rw-r--r--app-emacs/crux/metadata.xml23
4 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/crux/Manifest b/app-emacs/crux/Manifest
new file mode 100644
index 000000000000..12ad1752a855
--- /dev/null
+++ b/app-emacs/crux/Manifest
@@ -0,0 +1,4 @@
+AUX 50crux-gentoo.el 68 BLAKE2B aa0d55ea42ba6a69aa1e5efb11af7406b00b174f3973eeaae6a9ee964fcd296419dfda901ba1cf3a158c518c1514187fc4f00303e3b9f5de585d03e3f9753708 SHA512 25ce118d2fc11d9cd1816dcf1f6932664b8d58bf4603e29a1044b4c183df68aa0b59c9673ee762d938965315bdc4cc1287d66844fe9923e711bce943b0af16d9
+DIST crux-0.4.0.tar.gz 12611 BLAKE2B aa5655b703c81db3cd212caba0027873ccfe42e5b22e7534285d36b9eb9fc17178ee5d2b6500feb281f0fb82c18e599e7769d0a6647f75825695ea8eb5aba5c9 SHA512 d961d7f41a184c8521e4cd27e262feda4516807d3157e8ea79bc67086fe65d70be60673246bf3114ddaa50d25caa2622c85a62742e3cd230e5fe69a224ecfa5d
+EBUILD crux-0.4.0.ebuild 518 BLAKE2B 1b95fd48a8b4fd5db0b74e09d1e11c273bb04461af600f61177a252360137dd842bb864ff1a043e1874668352642011e617c43b494bb61346d3e43443a2f378c SHA512 733f94ed68b169e0e3ab33a56897208cff3b7311007025bf92e1aebe5c7caf75199a187ccc92fcfcda64c5c36d9b791d2884f8873e9028d11f23c4ae5fd5d5fd
+MISC metadata.xml 1052 BLAKE2B 704031f3fd9742ef3ba3a810f360d05807a8886c6d9fed9b5754cb5f3bbeaf36896a22538d95618245a98ecdc96d43c166ec6afd1c24cd1322b305ffad8c8e45 SHA512 541ae86099cafe40add9d79f18ed0b100dfa84cf1b87f7e19f34691aaea2c6f317c02a8ff5507c1e601012e8476138923d66666bbcea5ac545a09f5f1a617c26
diff --git a/app-emacs/crux/crux-0.4.0.ebuild b/app-emacs/crux/crux-0.4.0.ebuild
new file mode 100644
index 000000000000..29a1dfdebb87
--- /dev/null
+++ b/app-emacs/crux/crux-0.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Collection of Ridiculously Useful eXtensions for GNU Emacs"
+HOMEPAGE="https://github.com/bbatsov/crux/"
+SRC_URI="https://github.com/bbatsov/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/crux/files/50crux-gentoo.el b/app-emacs/crux/files/50crux-gentoo.el
new file mode 100644
index 000000000000..32881b6c6cc0
--- /dev/null
+++ b/app-emacs/crux/files/50crux-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "crux-autoloads" nil t)
diff --git a/app-emacs/crux/metadata.xml b/app-emacs/crux/metadata.xml
new file mode 100644
index 000000000000..870ec9222beb
--- /dev/null
+++ b/app-emacs/crux/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ A Collection of Ridiculously Useful eXtensions for Emacs. crux bundles many
+ useful interactive commands to enhance your overall Emacs experience. Most
+ of the crux commands are related to the editing experience, but there are
+ also a bunch of utility commands that are just very useful to have (e.g.
+ crux-open-with and crux-reopen-as-root). Many of the functions in crux
+ started life as blog posts on Emacs Redux, then were included in Emacs
+ Prelude, before finally being extracted to crux. You can see a full list of
+ blog posts on functions in crux on the tags page.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/bbatsov/crux/issues/</bugs-to>
+ <remote-id type="github">bbatsov/crux</remote-id>
+ </upstream>
+</pkgmetadata>