summaryrefslogtreecommitdiff
path: root/app-emacs/diff-hl/diff-hl-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
commit6c0d1528e3598898fd1026a3da35ffede0a1f14a (patch)
treed5ab9d7f6d2b41d05fb156069ee81e9ed779f12b /app-emacs/diff-hl/diff-hl-1.9.1.ebuild
parent29efd7db303b443e103311cc0e458ee5c134e8e5 (diff)
gentoo auto-resync : 06:01:2023 - 18:11:38
Diffstat (limited to 'app-emacs/diff-hl/diff-hl-1.9.1.ebuild')
-rw-r--r--app-emacs/diff-hl/diff-hl-1.9.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/diff-hl/diff-hl-1.9.1.ebuild b/app-emacs/diff-hl/diff-hl-1.9.1.ebuild
new file mode 100644
index 000000000000..5b323cff93f5
--- /dev/null
+++ b/app-emacs/diff-hl/diff-hl-1.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=8f2e4eb345f0639c8fc41e3f7576f77ba6987655
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Highlight uncommitted changes, jump between and revert them selectively"
+HOMEPAGE="https://github.com/dgutov/diff-hl/"
+SRC_URI="https://github.com/dgutov/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-vcs/git )"
+
+DOCS=( README.md screenshot{,-dired,-margin}.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ebegin "Creating a git repository for tests"
+ git init "${S}" --initial-branch="master" &&
+ git add "${S}" &&
+ git config --local user.email "test@test" &&
+ git config --local user.name "test" &&
+ git commit --message "test" --quiet
+ eend $? || die
+ emake EMACS="${EMACS} ${EMACSFLAGS}" test
+}