summaryrefslogtreecommitdiff
path: root/app-emacs/ebuild-run-mode/ebuild-run-mode-20210713.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /app-emacs/ebuild-run-mode/ebuild-run-mode-20210713.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'app-emacs/ebuild-run-mode/ebuild-run-mode-20210713.ebuild')
-rw-r--r--app-emacs/ebuild-run-mode/ebuild-run-mode-20210713.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/ebuild-run-mode/ebuild-run-mode-20210713.ebuild b/app-emacs/ebuild-run-mode/ebuild-run-mode-20210713.ebuild
new file mode 100644
index 000000000000..1489c2283048
--- /dev/null
+++ b/app-emacs/ebuild-run-mode/ebuild-run-mode-20210713.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS="24.5"
+
+inherit elisp
+
+MY_PN="emacs-${PN}"
+DESCRIPTION="Major mode for Emacs buffers where ebuild commands run"
+HOMEPAGE="https://gitlab.com/akater/emacs-ebuild-run-mode"
+SRC_URI="https://gitlab.com/akater/${MY_PN}/-/archive/v${PV}/${MY_PN}-v${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-v${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/ebuild-mode-1.53"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="ebuild-run-mode.org"
+
+src_compile() {
+ default
+}