summaryrefslogtreecommitdiff
path: root/app-emacs/elfeed-protocol
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-08 17:39:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-08 17:39:25 +0100
commitd6a3ca89e16356791af128f18ca5d5aeaf1323e0 (patch)
treefbc86af2b58d1e803aae486162ec1f1bc549b33e /app-emacs/elfeed-protocol
parentc53e4600c18a19ae2aaab501c1e5e7d6ceed23fe (diff)
gentoo auto-resync : 08:05:2023 - 17:39:25
Diffstat (limited to 'app-emacs/elfeed-protocol')
-rw-r--r--app-emacs/elfeed-protocol/Manifest4
-rw-r--r--app-emacs/elfeed-protocol/elfeed-protocol-0.8.1.ebuild29
-rw-r--r--app-emacs/elfeed-protocol/files/50elfeed-protocol-gentoo.el5
-rw-r--r--app-emacs/elfeed-protocol/metadata.xml18
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/elfeed-protocol/Manifest b/app-emacs/elfeed-protocol/Manifest
new file mode 100644
index 000000000000..fe1fea41ae69
--- /dev/null
+++ b/app-emacs/elfeed-protocol/Manifest
@@ -0,0 +1,4 @@
+AUX 50elfeed-protocol-gentoo.el 250 BLAKE2B c979151b26ed4f18dd202fbbae107dd0eb3a8fff3f55daa480351b6982a215cee8102b953413cf06bb2836ac5d97068ebd5190805ebba26ba5d6b01b425698bb SHA512 c7771e89a3dda4da04b91f7c9ce52043f53df6a95b98071b87c6680665cf6ecd1b09a5872135c4229c15d83814d284771ad93c7349a11d5ba002dcb5c74293d7
+DIST elfeed-protocol-0.8.1.tar.gz 48250 BLAKE2B 9a6491c29b1fe64bc7ced8e94548552b85b501279e60173bca0a8a11e5b624a17a51cdb035139620905ecde0c7c4dab0fed7a00f869af823123ca69c12dcfdc6 SHA512 846c39766d9312b3612b9d27ebe88e2aac153b2a3cd1683438b696004aaa4cb6d250b876c9669bf63a17a6fc6aaa6a0980550e962b19ab85268d6214ad4a022f
+EBUILD elfeed-protocol-0.8.1.ebuild 635 BLAKE2B 3c1822919592c5157cf13f23b2813dd927eb0bd93c54f2930da1e08ae3d403bd2d4b70b8db2d1456ac105ce8c7e87dcf04b49f4c6a8ca953915d7b914950c63e SHA512 223001c56b52d3addc25379df440b1b22e57a42bff048c4b1a9ea0732db474b740750bbce747060e900ff4295afeeeab4d409402ed32b546e087d7a769b88879
+MISC metadata.xml 647 BLAKE2B 6f4948342bfb58a61f60e7b3d4ffd1dd19042409ff2a5a162ea584058b22667ba1cb894fa88e8e992d0233739bfee64765e83680865b975baacbfe9fc0127ee5 SHA512 849d5863b942be20a5a1c8d562d15ebfeda15ff7b29e14282ed0b8f1859a67cc723061e8ee81dda2ae070e73fa6b1b7d94ebc9d31cd27a9965885fd1d6c7d737
diff --git a/app-emacs/elfeed-protocol/elfeed-protocol-0.8.1.ebuild b/app-emacs/elfeed-protocol/elfeed-protocol-0.8.1.ebuild
new file mode 100644
index 000000000000..1fd5f3db4117
--- /dev/null
+++ b/app-emacs/elfeed-protocol/elfeed-protocol-0.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Provide extra news client subscription protocols for elfeed"
+HOMEPAGE="https://github.com/fasheng/elfeed-protocol/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fasheng/${PN}.git"
+else
+ SRC_URI="https://github.com/fasheng/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="app-emacs/elfeed"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner test
diff --git a/app-emacs/elfeed-protocol/files/50elfeed-protocol-gentoo.el b/app-emacs/elfeed-protocol/files/50elfeed-protocol-gentoo.el
new file mode 100644
index 000000000000..788ac23ffeba
--- /dev/null
+++ b/app-emacs/elfeed-protocol/files/50elfeed-protocol-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'elfeed-protocol-disable "elfeed-protocol"
+ "Disable hooks and advices for elfeed-protocol." t)
+(autoload 'elfeed-protocol-enable "elfeed-protocol"
+ "Enable hooks and advices for elfeed-protocol." t)
diff --git a/app-emacs/elfeed-protocol/metadata.xml b/app-emacs/elfeed-protocol/metadata.xml
new file mode 100644
index 000000000000..7906f06796a4
--- /dev/null
+++ b/app-emacs/elfeed-protocol/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Provide extra protocols to make self-hosting RSS readers work with elfeed,
+ including Fever, NewsBlur, Nextcloud/ownCloud News, Tiny Tiny RSS and even
+ more.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/fasheng/elfeed-protocol/issues/</bugs-to>
+ <remote-id type="github">fasheng/elfeed-protocol</remote-id>
+ </upstream>
+</pkgmetadata>