summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-aio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-14 07:43:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-14 07:43:49 +0100
commitfe8b106bd60ab72e98ab836f5c702070805e197e (patch)
tree44016d57867c58de87efd4b028c171d352bbf3be /app-emacs/emacs-aio
parent30737dc88991519b90363c2c7bae8fd049098d13 (diff)
gentoo auto-resync : 14:10:2022 - 07:43:49
Diffstat (limited to 'app-emacs/emacs-aio')
-rw-r--r--app-emacs/emacs-aio/Manifest3
-rw-r--r--app-emacs/emacs-aio/emacs-aio-1.0_p20200610.ebuild28
-rw-r--r--app-emacs/emacs-aio/metadata.xml26
3 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/emacs-aio/Manifest b/app-emacs/emacs-aio/Manifest
new file mode 100644
index 000000000000..aecdf9eb4555
--- /dev/null
+++ b/app-emacs/emacs-aio/Manifest
@@ -0,0 +1,3 @@
+DIST emacs-aio-1.0_p20200610.tar.gz 9825 BLAKE2B f7d536b5ab603ec0506cf437e9819c00a84678dd1176ea83ac537c112767768a49bf6c95cc135255b252f83b1ecd47b6f195d5c812535f6c3c9843269e2c8750 SHA512 ac4b956a067d52130e57adb8c92bcd733b9566a1f8bfd03f721d7cb1479236346d8c65cf3c6d8475f9f5bb234f0fc766e2954d24af9feff891e1ece6a833c5d9
+EBUILD emacs-aio-1.0_p20200610.ebuild 560 BLAKE2B 887cd042cd6ede6fe145f89d2a2567426b2be1fae97274414d9cd6d4a4bd08e9102127488ba426fcd326dfd71d57794a980feebec70d9cbb65fc3318fde40858 SHA512 a002be3c0a8d3da800df1c703144ede7b2550b08e9d0aacb0c530c638e22c78776d26b790775b53f5a00a9e4767fcf114d885bf8b62075ad6c5225583f8e0a49
+MISC metadata.xml 1206 BLAKE2B 7a99fe205d238c47c5a813a5c969ba9c7271e3f674f5bf7b2a3ac04b57f9f73fd1e84d0bf452de3ef2c43d917af5f18968ed8cc069cbdc30b04aba5cb6125255 SHA512 41318d9ac989e097000da4997730ec842eb6c7434f6c9955034cee0759b23f10730de4ec572df68df0f9e18a602245273fc663eaa5e0a13d3aa1ab209d77591b
diff --git a/app-emacs/emacs-aio/emacs-aio-1.0_p20200610.ebuild b/app-emacs/emacs-aio/emacs-aio-1.0_p20200610.ebuild
new file mode 100644
index 000000000000..50a5d7e23baf
--- /dev/null
+++ b/app-emacs/emacs-aio/emacs-aio-1.0_p20200610.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=da93523e235529fa97d6f251319d9e1d6fc24a41
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Async and await functions for Emacs Lisp"
+HOMEPAGE="https://github.com/skeeto/emacs-aio/"
+SRC_URI="https://github.com/skeeto/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+src_compile() {
+ emake EMACS=${EMACS} compile
+}
+
+src_test() {
+ emake EMACS=${EMACS} check
+}
diff --git a/app-emacs/emacs-aio/metadata.xml b/app-emacs/emacs-aio/metadata.xml
new file mode 100644
index 000000000000..07a12f84c7c6
--- /dev/null
+++ b/app-emacs/emacs-aio/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ aio is to Emacs Lisp as asyncio is to Python. This package builds upon
+ Emacs 25 generators to provide functions that pause while they wait on
+ asynchronous events. They do not block any thread while paused. The main
+ components of this package are aio-defun/aio-lambda to define async
+ function, and aio-await to pause these functions while they wait on
+ asynchronous events. When an asynchronous function is paused, the main
+ thread is not blocked. It is no more or less powerful than callbacks, but
+ is nicer to use. This is implementation is based on Emacs 25 generators,
+ and asynchronous functions are actually iterators in disguise, operated as
+ stackless, asymmetric coroutines.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/skeeto/emacs-aio/issues/</bugs-to>
+ <remote-id type="github">skeeto/emacs-aio</remote-id>
+ </upstream>
+</pkgmetadata>