summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild')
-rw-r--r--app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild b/app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild
new file mode 100644
index 000000000000..c7e8c1954775
--- /dev/null
+++ b/app-emacs/emacs-el-fetch/emacs-el-fetch-3.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Show system information in Neofetch-like style inside Emacs"
+HOMEPAGE="https://gitlab.com/xgqt/emacs-el-fetch/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/xgqt/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/xgqt/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+src_compile() {
+ emake compile
+}
+
+src_install() {
+ einstalldocs
+ elisp-install ${PN} "${S}"/src/el-fetch/*.el{,c}
+ elisp-site-file-install "${S}"/extras/gentoo/50el-fetch-gentoo.el
+}