summaryrefslogtreecommitdiff
path: root/app-emacs/ess/ess-17.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/ess/ess-17.11.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/ess/ess-17.11.ebuild')
-rw-r--r--app-emacs/ess/ess-17.11.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/ess/ess-17.11.ebuild b/app-emacs/ess/ess-17.11.ebuild
new file mode 100644
index 000000000000..6cda31d72ab8
--- /dev/null
+++ b/app-emacs/ess/ess-17.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${P}.tgz"
+
+LICENSE="GPL-2+ GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # Most documentation is installed by the package's build system.
+ rm -f "${ED}${SITELISP}/${PN}/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf}
+ newdoc doc/ChangeLog ChangeLog-doc
+ newdoc lisp/ChangeLog ChangeLog-lisp
+
+ DOC_CONTENTS="Please see /usr/share/doc/${PF} for the complete
+ documentation. Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+ readme.gentoo_create_doc
+}