summaryrefslogtreecommitdiff
path: root/app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-05 21:20:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-05 21:20:55 +0100
commit2092ebe8b45cc45ad3357e2ccb2c37d5c1eaba2a (patch)
tree25c07bf0e025915c671c69127e02b8d201967e16 /app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild
parent2fc12e1ffd37b655f78c4277bd595010e18a8447 (diff)
gentoo auto-resync : 05:08:2023 - 21:20:55
Diffstat (limited to 'app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild')
-rw-r--r--app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild b/app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild
new file mode 100644
index 000000000000..28ccd181049b
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Ensure environment variables inside Emacs are the same as in shell"
+HOMEPAGE="https://github.com/purcell/exec-path-from-shell/"
+SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}