summaryrefslogtreecommitdiff
path: root/app-emacs/filladapt/filladapt-2.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 05:14:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 05:14:17 +0100
commit121b314457e147271cd95353cf8886d35b329845 (patch)
treed7f2f3186727afdecbfff3bac5e3b88c84d46625 /app-emacs/filladapt/filladapt-2.12.2.ebuild
parente87ef1b6ce856ae8859bdfce8028fb992f3e3763 (diff)
gentoo auto-resync : 16:09:2022 - 05:14:17
Diffstat (limited to 'app-emacs/filladapt/filladapt-2.12.2.ebuild')
-rw-r--r--app-emacs/filladapt/filladapt-2.12.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/filladapt/filladapt-2.12.2.ebuild b/app-emacs/filladapt/filladapt-2.12.2.ebuild
new file mode 100644
index 000000000000..e2880aa486fe
--- /dev/null
+++ b/app-emacs/filladapt/filladapt-2.12.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Filladapt enhances the behavior of Emacs' fill functions"
+HOMEPAGE="http://www.wonderworks.com/ https://elpa.gnu.org/packages/filladapt.html"
+SRC_URI="https://elpa.gnu.org/packages/${P}.el"
+S="${WORKDIR}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="Filladapt is not enabled as a site default. Add the following
+ lines to your ~/.emacs file to enable adaptive fill by default:
+ \n\t(require 'filladapt)
+ \n\t(setq-default filladapt-mode t)"
+
+src_unpack() {
+ mv "${DISTDIR}"/${P}.el "${WORKDIR}"/${PN}.el || die
+}