summaryrefslogtreecommitdiff
path: root/app-emacs/flycheck-clang-tidy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-23 06:44:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-23 06:44:33 +0000
commitdd5b71d2ad69f1887985ee1ca67b254e04157f73 (patch)
treee799be54f9ea7c4949c6a49c1a6f9667a7e1fef2 /app-emacs/flycheck-clang-tidy
parentbe14af2d51852951dbfea41913a7dd9d1190151e (diff)
gentoo auto-resync : 23:03:2023 - 06:44:33
Diffstat (limited to 'app-emacs/flycheck-clang-tidy')
-rw-r--r--app-emacs/flycheck-clang-tidy/Manifest4
-rw-r--r--app-emacs/flycheck-clang-tidy/files/50flycheck-clang-tidy-gentoo.el1
-rw-r--r--app-emacs/flycheck-clang-tidy/flycheck-clang-tidy-0.3.0_p20221116.ebuild30
-rw-r--r--app-emacs/flycheck-clang-tidy/metadata.xml16
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/flycheck-clang-tidy/Manifest b/app-emacs/flycheck-clang-tidy/Manifest
new file mode 100644
index 000000000000..032145270f35
--- /dev/null
+++ b/app-emacs/flycheck-clang-tidy/Manifest
@@ -0,0 +1,4 @@
+AUX 50flycheck-clang-tidy-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST flycheck-clang-tidy-0.3.0_p20221116.tar.gz 4485 BLAKE2B e7e760093c1f8e4e2b110ac85b1223959de66412e77a780788270e2a238b3e2abb0f4ba17861ee6a714f3cfd437f1b60d074d0beba7295651b553c7e9816b125 SHA512 f29bd187ceb72b58c4954e1aefe2ed1034a70bb9b4d8992e16d29bea5399374111cff29b96cb3d90ed4dbee15d1c3593b6365fabe7ad2e4669b01a2482558a64
+EBUILD flycheck-clang-tidy-0.3.0_p20221116.ebuild 712 BLAKE2B 494dbdea22dc9e539658eed5f6de52f951e3d1d532ae376bf8a3af357e6127f88749affe4bd4c8f7cdfe55fcc289c31ceb23c31c1ccf192baa7cc755aa8315b6 SHA512 5f09555a1fdf40494ec4396a209b666e19d306e38290cdf0eabb0ae33282ba5897a9c73b5a082322e05ba74a7837fb7c30ae54d9a5ec0a4552a22990c6b37211
+MISC metadata.xml 544 BLAKE2B 2645c273478d034b299a2a43cc4bb0966c2274565be5bd5da0150d1c68b3a0be249879ebb53375e7c1f7e6ce72c0e6c3b6a4cdda924f9a00b233788aa646b90e SHA512 61218cdeeff9f025c2640e1edabd4d36948c5014bc1656f26f5ae1cd4e7f4dd76b5ffca3502ab4bbcdbba9199ff82d61fa6908f751459d81d3532a1803956316
diff --git a/app-emacs/flycheck-clang-tidy/files/50flycheck-clang-tidy-gentoo.el b/app-emacs/flycheck-clang-tidy/files/50flycheck-clang-tidy-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/flycheck-clang-tidy/files/50flycheck-clang-tidy-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/flycheck-clang-tidy/flycheck-clang-tidy-0.3.0_p20221116.ebuild b/app-emacs/flycheck-clang-tidy/flycheck-clang-tidy-0.3.0_p20221116.ebuild
new file mode 100644
index 000000000000..d02cbfe8abda
--- /dev/null
+++ b/app-emacs/flycheck-clang-tidy/flycheck-clang-tidy-0.3.0_p20221116.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+inherit elisp
+
+DESCRIPTION="Flycheck syntax checker using clang-tidy"
+HOMEPAGE="https://github.com/ch1bo/flycheck-clang-tidy"
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT="f9ae7306bd6ca08b689b36c1e8f6f6b91d61db5f"
+ SRC_URI="https://github.com/ch1bo/flycheck-clang-tidy/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/ch1bo/flycheck-clang-tidy/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ >=app-emacs/flycheck-0.30
+"
+RDEPEND="
+ ${BDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/flycheck-clang-tidy/metadata.xml b/app-emacs/flycheck-clang-tidy/metadata.xml
new file mode 100644
index 000000000000..55a6a6ea0b59
--- /dev/null
+++ b/app-emacs/flycheck-clang-tidy/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/ch1bo/flycheck-clang-tidy/issues/</bugs-to>
+ <remote-id type="gitlab">ch1bo/flycheck-clang-tidy</remote-id>
+ </upstream>
+</pkgmetadata>