summaryrefslogtreecommitdiff
path: root/app-emacs/gnuplot-mode/gnuplot-mode-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-23 12:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-23 12:07:24 +0100
commit57dda344760f34c8c8f93c3c161ab10e55dc3860 (patch)
treec16ee3911f3aa264b3e28d6cd1a834014f1c030f /app-emacs/gnuplot-mode/gnuplot-mode-0.8.1.ebuild
parent98c7fa9070b6b423d52dfb59567ec7ef0d5f234d (diff)
gentoo auto-resync : 23:04:2023 - 12:07:24
Diffstat (limited to 'app-emacs/gnuplot-mode/gnuplot-mode-0.8.1.ebuild')
-rw-r--r--app-emacs/gnuplot-mode/gnuplot-mode-0.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/gnuplot-mode/gnuplot-mode-0.8.1.ebuild b/app-emacs/gnuplot-mode/gnuplot-mode-0.8.1.ebuild
new file mode 100644
index 000000000000..4384d2723260
--- /dev/null
+++ b/app-emacs/gnuplot-mode/gnuplot-mode-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Gnuplot mode for Emacs"
+HOMEPAGE="https://github.com/emacs-gnuplot/gnuplot"
+SRC_URI="https://github.com/emacs-gnuplot/${PN%-mode}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN%-mode}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc"
+
+BDEPEND="doc? ( virtual/latex-base )"
+RDEPEND="sci-visualization/gnuplot"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=(CHANGELOG.org README.org)
+DOC_CONTENTS="Please see ${SITELISP}/${PN}/gnuplot.el for the complete
+ documentation."
+
+src_compile() {
+ elisp_src_compile
+ use doc && { pdflatex gpelcard || die; }
+}
+
+src_install() {
+ elisp_src_install
+ use doc && dodoc gpelcard.pdf
+}