summaryrefslogtreecommitdiff
path: root/app-emacs/graphql/graphql-0.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 05:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 05:48:01 +0000
commit4bc834b03b9438dcfd45780f31a02994c24608ba (patch)
tree1ee84a24bd250533fbdadfa949f438db20ba98aa /app-emacs/graphql/graphql-0.1.2.ebuild
parent175512fa7c74d0e48a7a1b40a6e456435af0481b (diff)
gentoo auto-resync : 13:01:2023 - 05:48:01
Diffstat (limited to 'app-emacs/graphql/graphql-0.1.2.ebuild')
-rw-r--r--app-emacs/graphql/graphql-0.1.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/graphql/graphql-0.1.2.ebuild b/app-emacs/graphql/graphql-0.1.2.ebuild
new file mode 100644
index 000000000000..1ea6269125e9
--- /dev/null
+++ b/app-emacs/graphql/graphql-0.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+[[ "${PV}" == 0.1.2 ]] && H=67237f284f2dfb94f3cfba672ff64a37e1cb860f
+
+inherit elisp
+
+DESCRIPTION="GraphQL utilities"
+HOMEPAGE="https://github.com/vermiculus/graphql.el/"
+SRC_URI="https://github.com/vermiculus/graphql.el/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+# Tries to download emake tool on the fly
+RESTRICT="test"
+
+src_prepare() {
+ # Avoid examples which would require circular dependencies
+ rm -f ${PN}-examples.el || die
+
+ default
+}