summaryrefslogtreecommitdiff
path: root/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-14 15:13:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-14 15:13:45 +0100
commitb9e8f3cc44aed3b6da71c7510c6287bf7bbbc66b (patch)
tree4b47f3026f10252cff69e7a4346215a4da4f0f1c /app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild
parent3d952d0bfe7b386699eb32d1431deb0c538f044d (diff)
gentoo auto-resync : 14:06:2023 - 15:13:45
Diffstat (limited to 'app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild')
-rw-r--r--app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild b/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild
new file mode 100644
index 000000000000..55a2a4c34f3a
--- /dev/null
+++ b/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Gruvbox is a retro groove color scheme, now in Emacs"
+HOMEPAGE="https://github.com/greduan/emacs-theme-gruvbox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/greduan/emacs-theme-gruvbox.git"
+else
+ SRC_URI="https://github.com/greduan/emacs-theme-gruvbox/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/emacs-theme-gruvbox-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/autothemer-0.2
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"