summaryrefslogtreecommitdiff
path: root/app-emacs/howm/howm-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-02 16:50:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-02 16:50:29 +0100
commit1f6d51a43dbfcb87ef81da70c688d354560e846a (patch)
tree0a298c9f420161e29e935ba44206262169475726 /app-emacs/howm/howm-1.5.0.ebuild
parenta308b9d4bf7fb28a64aec9444316a00068c164f6 (diff)
gentoo auto-resync : 02:08:2023 - 16:50:29
Diffstat (limited to 'app-emacs/howm/howm-1.5.0.ebuild')
-rw-r--r--app-emacs/howm/howm-1.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/howm/howm-1.5.0.ebuild b/app-emacs/howm/howm-1.5.0.ebuild
new file mode 100644
index 000000000000..1e3fec90e3d5
--- /dev/null
+++ b/app-emacs/howm/howm-1.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Note-taking tool on Emacs"
+HOMEPAGE="https://howm.sourceforge.jp/"
+SRC_URI="http://howm.sourceforge.jp/a/${P}.tar.gz"
+
+LICENSE="GPL-1+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ --with-emacs \
+ --with-lispdir="${SITELISP}" \
+ EMACS="${EMACS} --no-site-file"
+}
+
+src_compile() {
+ emake -j1 EMACS="${EMACS} --no-site-file" </dev/null
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install </dev/null
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog
+}