summaryrefslogtreecommitdiff
path: root/app-emacs/ht/ht-2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/ht/ht-2.3.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/ht/ht-2.3.ebuild')
-rw-r--r--app-emacs/ht/ht-2.3.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/app-emacs/ht/ht-2.3.ebuild b/app-emacs/ht/ht-2.3.ebuild
index 2b56bec9cad3..aac3d564cceb 100644
--- a/app-emacs/ht/ht-2.3.ebuild
+++ b/app-emacs/ht/ht-2.3.ebuild
@@ -1,28 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit elisp
-IUSE=""
-
DESCRIPTION="The missing hash table library for Emacs"
HOMEPAGE="https://github.com/Wilfred/ht.el"
SRC_URI="https://github.com/Wilfred/ht.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ht.el-${PV}"
+
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
-DOCS="CHANGELOG.md README.md"
-
-SITEFILE="50${PN}-gentoo.el"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=app-emacs/dash-2.12.0
"
-DEPEND=${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/f
+ app-emacs/ert-runner
+ )
+"
-S="${WORKDIR}/ht.el-${PV}"
+DOCS="CHANGELOG.md README.md"
+SITEFILE="50${PN}-gentoo.el"
-# Requires unpackaged dependencies, e.g. Cask
-RESTRICT="test"
+src_test() {
+ ert-runner --reporter ert+duration --script || die
+}