summaryrefslogtreecommitdiff
path: root/app-emacs/htmlize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/htmlize
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/htmlize')
-rw-r--r--app-emacs/htmlize/Manifest6
-rw-r--r--app-emacs/htmlize/files/50htmlize-gentoo.el11
-rw-r--r--app-emacs/htmlize/htmlize-1.43.ebuild18
-rw-r--r--app-emacs/htmlize/htmlize-1.47.ebuild17
-rw-r--r--app-emacs/htmlize/metadata.xml9
5 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/htmlize/Manifest b/app-emacs/htmlize/Manifest
new file mode 100644
index 000000000000..a00f4bba574f
--- /dev/null
+++ b/app-emacs/htmlize/Manifest
@@ -0,0 +1,6 @@
+AUX 50htmlize-gentoo.el 543 BLAKE2B 65ee2f1bd7aeb315827301a74582d9c04ceacf898a5cdd9a72f6783bcc2e4d1f97d681f67daeea24fa3489ae7a4db02875161c20a88330edaaa828a0c37b3bb5 SHA512 7bc9bc6cd113ec9090223b6bf3f373b25da1e4330039be37186904360a515ea102b51c2c6567e9e3fed7f78c4c29a0f80642e35878a2af61e83772b8a5bad99e
+DIST htmlize-1.43.el.bz2 21018 BLAKE2B ff07571bda31c3733e3a5ef703625ea485721080d13ad28f7e2be3f7470cae7f00ebf7f7a899a7351942643c5f3b854f01918b9fd3175b8f7ba0ae9237665d42 SHA512 cdef3f8478862e9743cad23697775111fbd64737daa6e0525923cff1ccc8dfd20ad554e5e92ec99281d87acf9ecd358474761858c8c6639c5459234bf79d4be9
+DIST htmlize-1.47.el.xz 21544 BLAKE2B c00222fa39bbd530fae89b6a71cc515dd37cce4d787267eca9d23eddd9f3054b932df8908712971c46c28fc89921a42ac613e826d73094b333aa977335077f54 SHA512 2cca746f696d382336a800d3f15e6a5812afa7c6965d6695c501085ed6c8f447da8ee6ed31a27c240e9d70f7c30b91292ac60c0c903a7ca0d52f2a4bfedbf06f
+EBUILD htmlize-1.43.ebuild 399 BLAKE2B e5b22c1cd35481e4cd89200d42adcccd1ff6ab751e40927161b9095f938d9674b2646cfe6359153f97c4155e39f477785169e0b4442489a37934a663d3d6081e SHA512 f46ebc4c02904c46990d99fe860c7189dde0df5c74807d547809b7ef0207bfa1c152ec4c4701df7747f3bab0e6fbc5dd455b8aa8ec66cb39701f3f361266f33e
+EBUILD htmlize-1.47.ebuild 412 BLAKE2B e6ba52cf40a4941a1efa543d5d94bfc2fb521fbff3dfcf9086a89949c772634c44d566f8c4808badfa58c273a06107d6308f4bfd27ee6be7458186a0eed5d60f SHA512 0255f5a8d6b4d03f8ee3c502e59b719baf3842ceae9510254a2f533a8f08616d4a5e4d2ce747a3b567ad42864652e09f7f2504cf8d77d389e93caff3ad60019a
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/htmlize/files/50htmlize-gentoo.el b/app-emacs/htmlize/files/50htmlize-gentoo.el
new file mode 100644
index 000000000000..85dd15653999
--- /dev/null
+++ b/app-emacs/htmlize/files/50htmlize-gentoo.el
@@ -0,0 +1,11 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'htmlize-buffer "htmlize"
+ "Convert BUFFER to HTML, preserving colors and decorations." t)
+(autoload 'htmlize-region "htmlize"
+ "Convert the region to HTML, preserving colors and decorations." t)
+(autoload 'htmlize-file "htmlize"
+ "Load FILE, fontify it, convert it to HTML, and save the result." t)
+(autoload 'htmlize-many-files "htmlize"
+ "Convert FILES to HTML and save the corresponding HTML versions." t)
+(autoload 'htmlize-many-files-dired "htmlize"
+ "HTMLize dired-marked files." t)
diff --git a/app-emacs/htmlize/htmlize-1.43.ebuild b/app-emacs/htmlize/htmlize-1.43.ebuild
new file mode 100644
index 000000000000..e614aa73039a
--- /dev/null
+++ b/app-emacs/htmlize/htmlize-1.43.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="HTML-ize font-lock buffers in Emacs"
+HOMEPAGE="https://www.emacswiki.org/emacs/Htmlize
+ http://fly.srk.fer.hr/~hniksic/emacs/"
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/htmlize/htmlize-1.47.ebuild b/app-emacs/htmlize/htmlize-1.47.ebuild
new file mode 100644
index 000000000000..fa7ad085cc8a
--- /dev/null
+++ b/app-emacs/htmlize/htmlize-1.47.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="HTML-ize font-lock buffers in Emacs"
+HOMEPAGE="https://www.emacswiki.org/emacs/Htmlize
+ http://fly.srk.fer.hr/~hniksic/emacs/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/htmlize/metadata.xml b/app-emacs/htmlize/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/htmlize/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>