summaryrefslogtreecommitdiff
path: root/app-emacs/kaolin-themes/kaolin-themes-1.6.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-16 02:52:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-16 02:52:59 +0000
commitd17fad940dac9897b8b58d2f1d072869942696a5 (patch)
treee77cd567646e69b19c4e8a8b20a6b201c7f6966e /app-emacs/kaolin-themes/kaolin-themes-1.6.9.ebuild
parent20e7188871e6d724b707132f925b9872536a91a0 (diff)
gentoo auto-resync : 16:12:2023 - 02:52:59
Diffstat (limited to 'app-emacs/kaolin-themes/kaolin-themes-1.6.9.ebuild')
-rw-r--r--app-emacs/kaolin-themes/kaolin-themes-1.6.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/kaolin-themes/kaolin-themes-1.6.9.ebuild b/app-emacs/kaolin-themes/kaolin-themes-1.6.9.ebuild
new file mode 100644
index 000000000000..2d483b0db1ca
--- /dev/null
+++ b/app-emacs/kaolin-themes/kaolin-themes-1.6.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Set of eye pleasing themes for GNU Emacs"
+HOMEPAGE="https://github.com/ogdenwebb/emacs-kaolin-themes"
+
+MY_PN="emacs-${PN}"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URL="https://github.com/ogdenwebb/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/ogdenwebb/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+RDEPEND="app-emacs/autothemer"
+BDEPEND="${RDEPEND}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el themes/*.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc themes/*.el themes/*.elc
+ elisp-make-site-file "${SITEFILE}"
+}