summaryrefslogtreecommitdiff
path: root/app-emacs/macrostep/macrostep-0.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-19 16:15:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-19 16:15:42 +0100
commitac616584d4bcb8e2a2defb591e3b0643054fda5d (patch)
tree2a1c72220398765d90183db696285fa3262ecdad /app-emacs/macrostep/macrostep-0.9.2.ebuild
parent1b76d39d04711631f8d9c7961d19e993e718e53c (diff)
gentoo auto-resync : 19:05:2023 - 16:15:42
Diffstat (limited to 'app-emacs/macrostep/macrostep-0.9.2.ebuild')
-rw-r--r--app-emacs/macrostep/macrostep-0.9.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/macrostep/macrostep-0.9.2.ebuild b/app-emacs/macrostep/macrostep-0.9.2.ebuild
new file mode 100644
index 000000000000..c24309d913e4
--- /dev/null
+++ b/app-emacs/macrostep/macrostep-0.9.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Interactive macro-expander for Emacs"
+HOMEPAGE="https://github.com/joddie/macrostep/
+ https://github.com/emacsorphanage/macrostep/"
+SRC_URI="https://github.com/emacsorphanage/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . --load ${PN}-test.el || die "test failed"
+}
+
+src_install() {
+ rm macrostep-test.el{,c} || die
+
+ elisp_src_install
+}