summaryrefslogtreecommitdiff
path: root/app-emacs/mode-compile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/mode-compile
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/mode-compile')
-rw-r--r--app-emacs/mode-compile/Manifest4
-rw-r--r--app-emacs/mode-compile/files/50mode-compile-gentoo.el5
-rw-r--r--app-emacs/mode-compile/metadata.xml12
-rw-r--r--app-emacs/mode-compile/mode-compile-2.29.1.ebuild17
4 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/mode-compile/Manifest b/app-emacs/mode-compile/Manifest
new file mode 100644
index 000000000000..3a82c9d96f7b
--- /dev/null
+++ b/app-emacs/mode-compile/Manifest
@@ -0,0 +1,4 @@
+AUX 50mode-compile-gentoo.el 255 BLAKE2B e460d21b72893ea9e5252dfeedbf37346b19744e43ab53b555b25b069af1eaa0de82412dd8d7b3fc444c16076aa62093c31bb85dad98605c650147584c9a2e65 SHA512 4214eb678ef2ee902bce458f906d19cc90f2d2f793e34e45b98393dc0d6eddd29334bfbdf1983793aa840f827654b093519686bf643a9593df9b0cd5783d4241
+DIST mode-compile-2.29.1.tar.gz 22924 BLAKE2B 7ef71f958ffd5022ddcc64c07ef60822af5bc4a1f5deac5c4e57ce63cd9596d5f612d73eb9cdac627ecfef59e893d795afbeaa19b380b0cc4291bb4dc23fc05c SHA512 bc43d9cae411f5177ce70c736041db74c6db1dc5b766b22b92227e9e1324d304276bd104d8e3cac9ff5a877fc48b6da5b904e1acdb6cca7396fc7c26cc572815
+EBUILD mode-compile-2.29.1.ebuild 466 BLAKE2B b04ecade92aa4d1c5a2ff0b92c94997d1c01bceb5854974d58469106043a3f30755311fb7ffbf69578820a90f63de6cf7fa9f1f13befedf3ae3994df475fea99 SHA512 f1914be874deb0c3348a5e9fc2bcd071bb29bb2a5de4d82823bf777115ec6586bc129a5559df83872802ef87228da6a2bc2fc9e647d7edfc3396c61794749f88
+MISC metadata.xml 369 BLAKE2B 56dfde5c732f5121092dfca54c173eb806d84a4a8248f837253e51f05fdedde6e7b7553c3a407603dc44c4dc60131a57ba63ebc24937e33b661bf6ba0b588dd7 SHA512 fd187a9390a9f11a6ba7ed9c714caa26ef09d1d275c4135b192e476ac3d929e5d947fa507b0d0ea6f7a54a66fccba48df65ea1d887075db59b12976eb5d29ee7
diff --git a/app-emacs/mode-compile/files/50mode-compile-gentoo.el b/app-emacs/mode-compile/files/50mode-compile-gentoo.el
new file mode 100644
index 000000000000..d8dc2734d77a
--- /dev/null
+++ b/app-emacs/mode-compile/files/50mode-compile-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mode-compile "mode-compile"
+ "Command to compile current buffer file based on the major mode" t)
+(autoload 'mode-compile-kill "mode-compile"
+ "Command to kill a compilation launched by `mode-compile'" t)
diff --git a/app-emacs/mode-compile/metadata.xml b/app-emacs/mode-compile/metadata.xml
new file mode 100644
index 000000000000..1c9e6ccfa517
--- /dev/null
+++ b/app-emacs/mode-compile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">emacsmirror/mode-compile</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/mode-compile/mode-compile-2.29.1.ebuild b/app-emacs/mode-compile/mode-compile-2.29.1.ebuild
new file mode 100644
index 000000000000..9f05df6283b4
--- /dev/null
+++ b/app-emacs/mode-compile/mode-compile-2.29.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Smart command for compiling files according to major-mode"
+HOMEPAGE="https://github.com/emacsmirror/mode-compile
+ https://www.emacswiki.org/emacs/ModeCompile"
+SRC_URI="https://github.com/emacsmirror/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"