summaryrefslogtreecommitdiff
path: root/app-emacs/modus-themes/modus-themes-4.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-18 00:49:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-18 00:49:43 +0000
commitec33f4bcbd3944dc39c56a98cde12232684932cf (patch)
tree3f7cc55fc8e88c98187f129228aa74a73ddcb18a /app-emacs/modus-themes/modus-themes-4.4.0.ebuild
parent5c94a4b3d11ad7b169e23bd604cf403c96bf4f1c (diff)
gentoo auto-resync : 18:03:2024 - 00:49:43
Diffstat (limited to 'app-emacs/modus-themes/modus-themes-4.4.0.ebuild')
-rw-r--r--app-emacs/modus-themes/modus-themes-4.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/modus-themes/modus-themes-4.4.0.ebuild b/app-emacs/modus-themes/modus-themes-4.4.0.ebuild
new file mode 100644
index 000000000000..e3ecfc9b2f8f
--- /dev/null
+++ b/app-emacs/modus-themes/modus-themes-4.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Highly accessible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/modus-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}