summaryrefslogtreecommitdiff
path: root/app-emacs/muse/muse-3.20-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /app-emacs/muse/muse-3.20-r1.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'app-emacs/muse/muse-3.20-r1.ebuild')
-rw-r--r--app-emacs/muse/muse-3.20-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/muse/muse-3.20-r1.ebuild b/app-emacs/muse/muse-3.20-r1.ebuild
new file mode 100644
index 000000000000..c527c20ee472
--- /dev/null
+++ b/app-emacs/muse/muse-3.20-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="An authoring and publishing environment for Emacs"
+HOMEPAGE="https://www.gnu.org/software/emacs-muse/"
+SRC_URI="https://github.com/alexott/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+ GPL-2 MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+#IUSE="test"
+RESTRICT="test" #426546
+
+#DEPEND="test? ( app-emacs/htmlize )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el lisp/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo texi/muse.info
+ dodoc AUTHORS NEWS README ChangeLog*
+ dodoc -r contrib etc examples experimental scripts
+}