summaryrefslogtreecommitdiff
path: root/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220916.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 11:14:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 11:14:46 +0100
commitacb0389058b8ef612d851b1ab54fa37376c4b7f7 (patch)
treeb1e68406cfd137e951d13c4307e3c2fac7ae0087 /app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220916.ebuild
parent121b314457e147271cd95353cf8886d35b329845 (diff)
gentoo auto-resync : 16:09:2022 - 11:14:45
Diffstat (limited to 'app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220916.ebuild')
-rw-r--r--app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220916.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220916.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220916.ebuild
new file mode 100644
index 000000000000..b17eee1c1d08
--- /dev/null
+++ b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220916.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
+HOMEPAGE="https://gitweb.gentoo.org/proj/nxml-gentoo-schemas.git/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins schemas.xml *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}