summaryrefslogtreecommitdiff
path: root/app-emacs/parsebib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emacs/parsebib
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emacs/parsebib')
-rw-r--r--app-emacs/parsebib/Manifest4
-rw-r--r--app-emacs/parsebib/files/50parsebib-gentoo.el1
-rw-r--r--app-emacs/parsebib/metadata.xml17
-rw-r--r--app-emacs/parsebib/parsebib-3.1.ebuild28
4 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/parsebib/Manifest b/app-emacs/parsebib/Manifest
new file mode 100644
index 000000000000..0dd3e962022f
--- /dev/null
+++ b/app-emacs/parsebib/Manifest
@@ -0,0 +1,4 @@
+AUX 50parsebib-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST parsebib-3.1.tar.gz 19298 BLAKE2B 1588a9ef6e1642a612be2abb340d9127f8b8542ac2edda0deb5d9be28903443a33de877e44cefceba110332c022b8e4885a2927f172a447f035e9a5c0e65b5a5 SHA512 10dc25831693d271582b2d561401399e12ac3ccbc994dc95ae22fec800e1b242461deaa6a1c0ae5b20a1834baf88017b3ee42f1a53ac5d73f73a2f69c050c6c2
+EBUILD parsebib-3.1.ebuild 604 BLAKE2B f534310ef65572bad27355e505fa2e5925760dcd218786c3515a4899b6b0e2d78a20b35ff8c03e405e9798c0ed0d8bc427fd049ea9873ae007ff429935e8ef48 SHA512 43c0e3f48f27236e13b3c0ae7b4a28610affd2a9900fbdc72c81f96ea316deb13d13cd3508a5f9b6142c4056da6b1abfbdd8952ee5faea15d7ac5dcbda771459
+MISC metadata.xml 627 BLAKE2B c720728d95d1210afc6015d7472134e9078fbc67f591e4991dd34a780c49c8b30c1dec30c6ce57d81034f71895aafb8637c8181d7cdc9e13819ecceea919cc98 SHA512 a991dcfa3ddc97afc341228c4483c888de999eb79f67cb174e12a8d9725da58468c6e1330d8f5e2ef7e947e108e6eba1edba4fceca7955793b6d8a0c223d1f4a
diff --git a/app-emacs/parsebib/files/50parsebib-gentoo.el b/app-emacs/parsebib/files/50parsebib-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/parsebib/files/50parsebib-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/parsebib/metadata.xml b/app-emacs/parsebib/metadata.xml
new file mode 100644
index 000000000000..0892b478df27
--- /dev/null
+++ b/app-emacs/parsebib/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/joostkremers/parsebib/issues/</bugs-to>
+ <remote-id type="github">joostkremers/parsebib</remote-id>
+ </upstream>
+ <longdescription>
+ Parsebib is an Elisp library for reading bibliographic database files. It
+ supports both BibTeX / biblatex (.bib) files and CSL-JSON (.json) files.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emacs/parsebib/parsebib-3.1.ebuild b/app-emacs/parsebib/parsebib-3.1.ebuild
new file mode 100644
index 000000000000..6d23c9db04f0
--- /dev/null
+++ b/app-emacs/parsebib/parsebib-3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp library for reading .bib files"
+HOMEPAGE="https://github.com/joostkremers/parsebib/"
+SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}