summaryrefslogtreecommitdiff
path: root/app-emacs/parsebib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-10 00:12:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-10 00:12:21 +0000
commit3a81cede4783e464b7485722b2eaac0280dbc570 (patch)
tree261618bfbe562244c237d48a7960d4952bc6b318 /app-emacs/parsebib
parentb95a6fd4a7b591baa7cfc689f8ce5643592d07be (diff)
gentoo auto-resync : 10:02:2025 - 00:12:20
Diffstat (limited to 'app-emacs/parsebib')
-rw-r--r--app-emacs/parsebib/Manifest2
-rw-r--r--app-emacs/parsebib/parsebib-6.6.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/parsebib/Manifest b/app-emacs/parsebib/Manifest
index f5f6cb12beb9..d22371d3be57 100644
--- a/app-emacs/parsebib/Manifest
+++ b/app-emacs/parsebib/Manifest
@@ -1,3 +1,5 @@
DIST parsebib-6.4.gh.tar.gz 29833 BLAKE2B a7ab75df71adb991aa7b58729a54a9169e84de0d435b7a6ed23cd2b48df31cbf798dca996c0c9ff0964057296e0086fe4df6846b225786b893a0e0ccf7f7916f SHA512 ef54f99da612f1514af17a8e673d2dabfdf091c24b759f2fc09f398faadaf35713ddafffb5aa76ba1aad8ddbeb43571c426bfb07df9d27e197601adfcf39c8e7
+DIST parsebib-6.6.gh.tar.gz 30312 BLAKE2B 254087508b80d412ace54511993deec874c141b971eb82c978de15d590ba3d82d056a2d98010c404eb0089f72aa2de6baf524143e741c98b61cf0a07ede3337d SHA512 b622dc8fdc664dae64ce86935d2f84e12e7e4bf6a1f57890277ed38659b0b7d083efebb18fa09914afe308cb6dbb6ae49ddc09b4f161b7ad9b7cfb2b5791cd9b
EBUILD parsebib-6.4.ebuild 579 BLAKE2B 3e4ea27e903ebda1182fd2a038748425a9b266c588f2eb92d20c9fb3e5b664e61a9bae66eb773372326204d5b47080888fbcb5dca7b1aa6f21d3aa4c778daa03 SHA512 a151cc194445934d7cb15cafd42f130acab70a949a37e4ee4aa4d2a04de25829282633d227ee5e3a0e094c6af666891daeb3c3f8128c370a8647d70c42037311
+EBUILD parsebib-6.6.ebuild 580 BLAKE2B 34a8d23bbaf363adfad2934847ae29d8861c6034849e5414832ec90d8132d2c42981bcea78c7b10aac3e2543b76a82bbc9aed7295f5565eec9a75822f40f30ab SHA512 919cbbbbc19a6e5f7cb887c956424bc952cc0996080112d6ac96f181acecf7b2d5fff1d2d9d974d609ba295a5b1555f2099956cb26cb0983a12ae43ad924de3f
MISC metadata.xml 627 BLAKE2B c720728d95d1210afc6015d7472134e9078fbc67f591e4991dd34a780c49c8b30c1dec30c6ce57d81034f71895aafb8637c8181d7cdc9e13819ecceea919cc98 SHA512 a991dcfa3ddc97afc341228c4483c888de999eb79f67cb174e12a8d9725da58468c6e1330d8f5e2ef7e947e108e6eba1edba4fceca7955793b6d8a0c223d1f4a
diff --git a/app-emacs/parsebib/parsebib-6.6.ebuild b/app-emacs/parsebib/parsebib-6.6.ebuild
new file mode 100644
index 000000000000..824632b28588
--- /dev/null
+++ b/app-emacs/parsebib/parsebib-6.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp library for reading .bib files"
+HOMEPAGE="https://github.com/joostkremers/parsebib/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joostkremers/${PN}.git"
+else
+ SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner test