summaryrefslogtreecommitdiff
path: root/app-emacs/parseedn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-30 17:40:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-30 17:40:25 +0100
commit3c78a1ce7924fbf571e133e697f8a29e18d2bf4b (patch)
tree5bbedb5d3c2716d5b332f7e74f54941c9a2b50b8 /app-emacs/parseedn
parentc417025a2ab386cddabb71ad598a9b75b47af313 (diff)
gentoo auto-resync : 30:09:2023 - 17:40:25
Diffstat (limited to 'app-emacs/parseedn')
-rw-r--r--app-emacs/parseedn/Manifest2
-rw-r--r--app-emacs/parseedn/parseedn-1.2.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/parseedn/Manifest b/app-emacs/parseedn/Manifest
index e4c32a642521..8619954be373 100644
--- a/app-emacs/parseedn/Manifest
+++ b/app-emacs/parseedn/Manifest
@@ -1,3 +1,5 @@
DIST parseedn-1.1.0.tar.gz 10455 BLAKE2B 2ffe006f254e34ad31e266ceb365cdc1532c4a4c3aaf2d0bd3e26791de560be5662d292436ad4dc4fb6d931e17a319443032ff4949e5e9e86ccf15d90ddac3b6 SHA512 cd7b2070e15f7ddf8ae9f01424400f04b638765c518ae00b3a07ca55de308d79da5aaafdcb1b58e04bc833ddd7c5842d102ff2a6f63ab8d4f6125dbb84bb375a
+DIST parseedn-1.2.0.tar.gz 12122 BLAKE2B c7f9a370df9a58ee2b82c99361014964f879722fc8c17759bc2b4ec72d507e2e230792402f93f96ce278875800dfc7b56ad2035328398b277ef96d4f4d8cc2ff SHA512 56c06daa38a973aadc1cd14763bb28148e8df5a3ef886a087d45e12857c291accc01d18f136b85e27bea561dba8731de2691426c8da7a089052a6336d5a91122
EBUILD parseedn-1.1.0.ebuild 701 BLAKE2B 0ac5d71abc87f66d8289de624e7c0b83fd4b694626e971cc2aba9441d05c2924e2f0d2a4cc346da22ae3f43d1c9c1ba1a3ef9c4071d5214acb56f4d36815eec0 SHA512 a68a083d5322116c57e4368508458ba2b3fe694f77961b3b67f9b457687694f779cd3184faf0704bdad15ccbae270fcef86fd22a2ebf4d393d55c4a0947b8dc0
+EBUILD parseedn-1.2.0.ebuild 702 BLAKE2B c4920cf914a202292d57d7ca4c3ab3b481b896d4d0f19c1c1d7d8ce9b424667734ba71e5eef4294c0274c8a7d8435f1b73f426aa580250b46439736271dc289b SHA512 58b45788b2f3558fd1fff6539d26a536f64804a4b29a7e9c3b6743e797cc0b3c55640491c84d1cb076f7edb342d0c76df4b85df0adf8b98c4232eebb549dd4ae
MISC metadata.xml 935 BLAKE2B 59252290a86d7d03fc9dc71632cad89371d16421cbb3a5347410a25eb65f5f0ced1cb65334769e3e5a6043e6db4456104fccebe4d9aec5f9dd1534b9315d7403 SHA512 86f674633ee4319162836f77aafa94f4fbb50d992716bd66a678ef5db9d4311a7911522fbc6e2ac8351f7c075ba7f49b08e90d4e1a862a091a7790de2b627918
diff --git a/app-emacs/parseedn/parseedn-1.2.0.ebuild b/app-emacs/parseedn/parseedn-1.2.0.ebuild
new file mode 100644
index 000000000000..40ac9c025de4
--- /dev/null
+++ b/app-emacs/parseedn/parseedn-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="EDN parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseedn/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/parseclj"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/ert-runner )
+"
+
+ELISP_REMOVE="test/${PN}-test.el" # Remove bad tests.
+DOCS=( CHANGELOG.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}