summaryrefslogtreecommitdiff
path: root/app-emacs/projectile/projectile-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-27 09:57:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-27 09:57:18 +0100
commitc70685892bc3f0b09aea1216ff278f6095f21281 (patch)
tree4f39843e13c4d3bfd7d02fcfde9adf66af6063b0 /app-emacs/projectile/projectile-2.6.0.ebuild
parent6e8f2ebdce568f2c6c7870edbb9db5324a0e300f (diff)
gentoo auto-resync : 27:10:2022 - 09:57:18
Diffstat (limited to 'app-emacs/projectile/projectile-2.6.0.ebuild')
-rw-r--r--app-emacs/projectile/projectile-2.6.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/projectile/projectile-2.6.0.ebuild b/app-emacs/projectile/projectile-2.6.0.ebuild
new file mode 100644
index 000000000000..26f4e8b00c5e
--- /dev/null
+++ b/app-emacs/projectile/projectile-2.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="25.1"
+
+inherit elisp
+
+DESCRIPTION="A project interaction library for Emacs"
+HOMEPAGE="https://docs.projectile.mx"
+SRC_URI="https://github.com/bbatsov/projectile/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+SITEFILE="50projectile-gentoo.el"
+DOCS=( README.md )
+
+src_test() {
+ mkdir -p "${HOME}"/.emacs.d || die # For "projectile--directory-p" test
+ buttercup -L . -L test --traceback full || die
+}