summaryrefslogtreecommitdiff
path: root/app-emacs/reazon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-30 02:56:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-30 02:56:37 +0000
commit61966498b463d88a09132a9a22c68c0c37159e41 (patch)
tree25b9048d3a714990a1d984b2313aea0a9771b0e8 /app-emacs/reazon
parent40a4dd47c275aca60d7381a93635d31b8d09451a (diff)
gentoo auto-resync : 30:01:2023 - 02:56:37
Diffstat (limited to 'app-emacs/reazon')
-rw-r--r--app-emacs/reazon/Manifest4
-rw-r--r--app-emacs/reazon/files/50reazon-gentoo.el1
-rw-r--r--app-emacs/reazon/metadata.xml22
-rw-r--r--app-emacs/reazon/reazon-0.4.1.ebuild20
4 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/reazon/Manifest b/app-emacs/reazon/Manifest
new file mode 100644
index 000000000000..02e9b0782c60
--- /dev/null
+++ b/app-emacs/reazon/Manifest
@@ -0,0 +1,4 @@
+AUX 50reazon-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST reazon-0.4.1.tar.gz 38654 BLAKE2B 1e2cc22c58b030bb504c47d5526b01a2f8d64f0e1fc95456313199defc847c0066aee3931d57c27592919a57633905951d3ab67cfa4a61035946609c772cf685 SHA512 fda8cda62bdf0818990a3a9bb5893b75bd4e875ecb6e6a280a1992e1d9b4b621e8ee7eac8e1d3ec0e06bf9bc8a37414695702247e5782e2859e4d8126906bf5f
+EBUILD reazon-0.4.1.ebuild 468 BLAKE2B 3cd661a4f317fa2250072592251cdc779bd41ddb470fc084da2d0f8037aa3d2227c7c0d70de18c9513691c3b22b5704ad8838048d34dc8484969cdd2aa2cb977 SHA512 a701a3d5f5fc4428531c5b24c56dcb22d516752773fbbff14fed1e7293917477669fa5941fe67ec3ceb6675aced72cb763fad07e059b8e9007e4cab9e0312667
+MISC metadata.xml 984 BLAKE2B 238aa2ec500f9f9573be2878b348149c049a141781669457b8f93be13029405d2278ce32fbee2339057526a36b498601c2c39fbff38aed8d6d3b25c348388269 SHA512 37d32e015675fa0148c70af6fc49bb857fd929c1b3c0597c7ee78e48e1e003159ff480e670375e79561b3cb5173835906921aa1622f976298dae815d2afe5515
diff --git a/app-emacs/reazon/files/50reazon-gentoo.el b/app-emacs/reazon/files/50reazon-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/reazon/files/50reazon-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/reazon/metadata.xml b/app-emacs/reazon/metadata.xml
new file mode 100644
index 000000000000..8b0170cd063f
--- /dev/null
+++ b/app-emacs/reazon/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Reazon is an Emacs implementation of miniKanren, a small domain-specific
+ logic programming language. Whereas languages like Elisp deal with
+ functions that take inputs and yield outputs, miniKanren deals with sets of
+ values that satisfy relations. Every function is a relation, but not vice
+ versa, since a relation might include the output of a function but not its
+ inputs. In such a case, miniKanren would attempt to find inputs yielding
+ the output, effectively running the function backwards.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/nickdrozd/reazon/issues/</bugs-to>
+ <remote-id type="github">nickdrozd/reazon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/reazon/reazon-0.4.1.ebuild b/app-emacs/reazon/reazon-0.4.1.ebuild
new file mode 100644
index 000000000000..e86dc1835a0b
--- /dev/null
+++ b/app-emacs/reazon/reazon-0.4.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs implementation of miniKanren, logic programming language"
+HOMEPAGE="https://github.com/nickdrozd/reazon/"
+SRC_URI="https://github.com/nickdrozd/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"