summaryrefslogtreecommitdiff
path: root/app-emacs/sml-mode/sml-mode-6.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emacs/sml-mode/sml-mode-6.10.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emacs/sml-mode/sml-mode-6.10.ebuild')
-rw-r--r--app-emacs/sml-mode/sml-mode-6.10.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/sml-mode-6.10.ebuild b/app-emacs/sml-mode/sml-mode-6.10.ebuild
new file mode 100644
index 000000000000..25af30594232
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="https://elpa.gnu.org/packages/sml-mode.html
+ http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from https://elpa.gnu.org/packages/${P}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}