summaryrefslogtreecommitdiff
path: root/app-emacs/sml-mode/sml-mode-6.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /app-emacs/sml-mode/sml-mode-6.9.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'app-emacs/sml-mode/sml-mode-6.9.ebuild')
-rw-r--r--app-emacs/sml-mode/sml-mode-6.9.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/sml-mode-6.9.ebuild b/app-emacs/sml-mode/sml-mode-6.9.ebuild
new file mode 100644
index 000000000000..dd9b5fb272ab
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="https://elpa.gnu.org/packages/sml-mode.html
+ http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from https://elpa.gnu.org/packages/${P}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}