summaryrefslogtreecommitdiff
path: root/app-emacs/tempel/tempel-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 17:52:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 17:52:12 +0000
commita90c84e720803f3d26c0ade8f1f1e405ca97502a (patch)
treef788ea0972d51c66823825021dd83427e1d466c4 /app-emacs/tempel/tempel-0.6.ebuild
parent07c1e2fbaa2f7d2cad4c16a747cebcf7ae7a6724 (diff)
gentoo auto-resync : 14:01:2023 - 17:52:11
Diffstat (limited to 'app-emacs/tempel/tempel-0.6.ebuild')
-rw-r--r--app-emacs/tempel/tempel-0.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/tempel/tempel-0.6.ebuild b/app-emacs/tempel/tempel-0.6.ebuild
new file mode 100644
index 000000000000..1d707c8aabb8
--- /dev/null
+++ b/app-emacs/tempel/tempel-0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Templates with in-buffer field editing for GNU Emacs"
+HOMEPAGE="https://github.com/minad/tempel/"
+SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}