summaryrefslogtreecommitdiff
path: root/app-emacs/tempel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-21 00:31:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-21 00:31:17 +0000
commitae832415103492f73a8351ed7a91cb596392d779 (patch)
tree50b8927d2d57e707e7e3402895a997ebbc349dda /app-emacs/tempel
parent77684468238b8755c1aa3e72f3055f4e62fcf14c (diff)
gentoo auto-resync : 21:03:2025 - 00:31:16
Diffstat (limited to 'app-emacs/tempel')
-rw-r--r--app-emacs/tempel/Manifest4
-rw-r--r--app-emacs/tempel/tempel-1.4.ebuild40
-rw-r--r--app-emacs/tempel/tempel-9999.ebuild14
3 files changed, 53 insertions, 5 deletions
diff --git a/app-emacs/tempel/Manifest b/app-emacs/tempel/Manifest
index 84ea27999ef4..47ea77348b64 100644
--- a/app-emacs/tempel/Manifest
+++ b/app-emacs/tempel/Manifest
@@ -1,5 +1,7 @@
AUX 50tempel-gentoo.el 70 BLAKE2B e302aa20f0a3b8c1b4291520a84b680ded0f26468fc74dd1d57a5f52693e05eb88ee8ddf673c2ad57c3055b5c2e933e6ff119d4016f482e99c0d985bf610b4d0 SHA512 2cb452a2623403100400cd5e74af0741d56cd2d89e93e49245cb86ff09be0d8289fae9760a1fadc637736549da6f0c0b528ea3e02ee495b0ced2093191286c90
DIST tempel-1.3.tar.gz 27980 BLAKE2B fc094edcb137420ddb484417a86006bafca999d455dd1a7e532e85e30936e9db807e0618673688088739b9af245fb162d8d026f260c9e2f9bc5651d3118a12a3 SHA512 bad06d73882caf2e1624d8610182c5a264450121d2fc5425ad4a0d7075a33ccdf27f0252d54592730a5a58758a5b038201d7303d11f4101802f71cba0d9f66ca
+DIST tempel-1.4.tar.gz 28106 BLAKE2B 87a4bb8fdf36b67b1633c1de45ac5895ef106740fbc7477abbd7a1027ba50bc506596da8344ee595a9d004dbc3265ffe86b6b307ee67a38a68d5fefa0989c311 SHA512 316b07b0faac9fd9d69e87271c722b93a9f19bc46adb366eccc1c5c1f918c1ff1e17bcef7e739f309ec4141a38bc6c77cf9395497670105b10aed689bedf1581
EBUILD tempel-1.3.ebuild 679 BLAKE2B eb1006795198f30ca69a38dcf35d61c9ed1f5ef939d763aef7191e6d5666a53debf56e27c27f4af22dbaa2a7170e4d246e5aea942bebe10eca11ca1cd5168369 SHA512 5eba7a23d95819bfd77cdde00dc93a0957d6bc423f20d604a352b77117e2d8b900b5b159b5fde93a2338e8906f27c0a870587c0715478b49afe469573788f32c
-EBUILD tempel-9999.ebuild 670 BLAKE2B 10c93eef98604d4f607dd2a9a7961d91873dbb78b8728418281c16e75fb5fd66c258df4cb121efb13cf39ed36d3a9b4b351b46cef0595491a8992cef29bcf58d SHA512 0b3161dcee223f5743a8b7afd0c9536035d95e8bb83a0322ef565f929ba1c275e985a6afc724a041428e24c7374582bced03c14a161d20ca2b69865aa5bfe8bc
+EBUILD tempel-1.4.ebuild 680 BLAKE2B 0927be9c1c19c6de654b86f5291cb109b14d2b8e05f39665e8c5c5444d8072b1dccb837609dd6a92434b5de30fa855c046bed28b05c55b680f0cba52636210a2 SHA512 d817b881c6a9d7a5c27c7a1c7653bff43997e3d75c645185730f18ccddcbfae83075f1ebfe7e589fa062827558e75b4cf4197cb458ecd61780af00ccb52a9dce
+EBUILD tempel-9999.ebuild 680 BLAKE2B 0927be9c1c19c6de654b86f5291cb109b14d2b8e05f39665e8c5c5444d8072b1dccb837609dd6a92434b5de30fa855c046bed28b05c55b680f0cba52636210a2 SHA512 d817b881c6a9d7a5c27c7a1c7653bff43997e3d75c645185730f18ccddcbfae83075f1ebfe7e589fa062827558e75b4cf4197cb458ecd61780af00ccb52a9dce
MISC metadata.xml 1061 BLAKE2B 66cacf45b54293c3fdac36e5065d1d4fe8680000b159865ffe03497f419ca0c85061e434fad577427b089e73ebc0323749f6e8998fd9a5ed852b98fba9ccc274 SHA512 28ffdd3968da62e9219133cf9db5092e30c6ae344f86cb2418482666a0ee71f5272cbe6ff0bfa85fb9b2d3b0fc185eabb75c0087bacfeef33e1840fbfbb5b04a
diff --git a/app-emacs/tempel/tempel-1.4.ebuild b/app-emacs/tempel/tempel-1.4.ebuild
new file mode 100644
index 000000000000..af41592833e7
--- /dev/null
+++ b/app-emacs/tempel/tempel-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Templates with in-buffer field editing for GNU Emacs"
+HOMEPAGE="https://github.com/minad/tempel/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.2.0
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/tempel/tempel-9999.ebuild b/app-emacs/tempel/tempel-9999.ebuild
index 8a32fe684d94..af41592833e7 100644
--- a/app-emacs/tempel/tempel-9999.ebuild
+++ b/app-emacs/tempel/tempel-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-NEED_EMACS=27.1
+NEED_EMACS="27.1"
inherit elisp
@@ -12,18 +12,24 @@ HOMEPAGE="https://github.com/minad/tempel/"
if [[ ${PV} == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/minad/${PN}.git"
else
SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
-> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
-RDEPEND=">=app-emacs/compat-29.1.3.4"
-BDEPEND="${RDEPEND}"
+RDEPEND="
+ >=app-emacs/compat-30.0.2.0
+"
+BDEPEND="
+ ${RDEPEND}
+"
DOCS=( README.org )
SITEFILE="50${PN}-gentoo.el"