summaryrefslogtreecommitdiff
path: root/app-emacs/transient/transient-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-28 21:15:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-28 21:15:34 +0100
commit14bda3c9c57c13e8a59303f400678313fd770bdd (patch)
tree1d76323e4e249e0515128cd6ca42e167a9575294 /app-emacs/transient/transient-9999.ebuild
parente5346f2f512bd7faf413f3de3ef7fbcfbcd974b3 (diff)
gentoo auto-resync : 28:05:2023 - 21:15:34
Diffstat (limited to 'app-emacs/transient/transient-9999.ebuild')
-rw-r--r--app-emacs/transient/transient-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/transient/transient-9999.ebuild b/app-emacs/transient/transient-9999.ebuild
new file mode 100644
index 000000000000..adb9d5ff1a85
--- /dev/null
+++ b/app-emacs/transient/transient-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org docs/${PN}.org )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND=">=app-emacs/compat-29.1.4.1"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}