summaryrefslogtreecommitdiff
path: root/app-emacs/transient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /app-emacs/transient
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'app-emacs/transient')
-rw-r--r--app-emacs/transient/Manifest4
-rw-r--r--app-emacs/transient/files/50transient-gentoo.el1
-rw-r--r--app-emacs/transient/metadata.xml35
-rw-r--r--app-emacs/transient/transient-0.3.4.ebuild29
4 files changed, 69 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
new file mode 100644
index 000000000000..9a5d3f449bfc
--- /dev/null
+++ b/app-emacs/transient/Manifest
@@ -0,0 +1,4 @@
+AUX 50transient-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST transient-0.3.4.tar.gz 100193 BLAKE2B 0dd91cf1af22cfd6c3b6fefaa1b84ba3a241e269aef5165befa9408171f8b5477b04e2886e690cfd8d20af31e83fe669e05f0bf40c3391aab353d33a59345689 SHA512 feb24bf9045c9212a45cbc0a99805bdad6f4f5871279d44c64a883ad5d33a40128189525ee546d6cff14bf2d60d3c1e684cf8894fefc01860e363073eafea220
+EBUILD transient-0.3.4.ebuild 644 BLAKE2B c9d4448a5fbb145a2c687a1d1b368a50f49616a0869ff0e7714e7dd89d62c2b464f7ebbc1c473be394ac8bfbe2869b0e063887ceeb15b8fef9cde342f4e3d899 SHA512 cda1012b7d316c14f7d523e049075cd180c5a496d72527197c8a9166a84b14dc058b75c437237e4cd00fd4aafa1016dad9d6ce27f3752cae0f8e42a51db98908
+MISC metadata.xml 1433 BLAKE2B 3c11fda17dd792b22a2523162f83b9c0ea0526c80a9a1352127cd1df534fd66a78973e55a66f98ebe02be443621d8463a133dc80a71017b1b0d48cf7a56ed67d SHA512 4424e241b27f4c4594df85a8c4114e07a3a12a2c9e81208b37661a36f2b91503fa77c1a74bdfd881c7ea4b7f239d6d8233c0bfd89665657ddb09def7ceb6b3cb
diff --git a/app-emacs/transient/files/50transient-gentoo.el b/app-emacs/transient/files/50transient-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/transient/files/50transient-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/transient/metadata.xml b/app-emacs/transient/metadata.xml
new file mode 100644
index 000000000000..f01b2556a6ac
--- /dev/null
+++ b/app-emacs/transient/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ Taking inspiration from prefix keys and prefix arguments, Transient
+ implements a similar abstraction involving a prefix command, infix
+ arguments and suffix commands. We could call this abstraction a
+ "transient command", but because it always involves at least two
+ commands (a prefix and a suffix) we prefer to call it just a
+ "transient".
+
+ When the user calls a transient prefix command, then a transient
+ (temporary) keymap is activated, which binds the transient's infix
+ and suffix commands, and functions that control the transient state
+ are added to `pre-command-hook' and `post-command-hook'. The
+ available suffix and infix commands and their state are shown in
+ the echo area until the transient is exited by invoking a suffix
+ command.
+
+ Calling an infix command causes its value to be changed, possibly
+ by reading a new value in the minibuffer.
+
+ Calling a suffix command usually causes the transient to be exited
+ but suffix commands can also be configured to not exit the
+ transient state.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">magit/transient</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/transient/transient-0.3.4.ebuild b/app-emacs/transient/transient-0.3.4.ebuild
new file mode 100644
index 000000000000..5f2eb4af6a92
--- /dev/null
+++ b/app-emacs/transient/transient-0.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/transient"
+SRC_URI="https://github.com/magit/transient/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="docs/*.texi"
+DOCS="README.md docs/transient.org"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} sys-apps/texinfo"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}