summaryrefslogtreecommitdiff
path: root/app-emacs/websocket/websocket-1.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emacs/websocket/websocket-1.13.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emacs/websocket/websocket-1.13.ebuild')
-rw-r--r--app-emacs/websocket/websocket-1.13.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/websocket/websocket-1.13.ebuild b/app-emacs/websocket/websocket-1.13.ebuild
new file mode 100644
index 000000000000..f9c4df32459b
--- /dev/null
+++ b/app-emacs/websocket/websocket-1.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A websocket implementation in elisp"
+HOMEPAGE="https://github.com/ahyatt/emacs-websocket"
+SRC_URI="https://github.com/ahyatt/emacs-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/emacs-${P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile websocket.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l websocket-test \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp-install ${PN} websocket.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org websocket-functional-test.el testserver.py
+}