summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 17:46:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 17:46:59 +0100
commit54654470d999265b5a0010be7190e8a9993b1840 (patch)
treecb6b99a56837c648a69859da9333e5b9a726912d /app-emacs
parent2046683958d0497bec1458741dc867558b69e622 (diff)
gentoo auto-resync : 11:05:2023 - 17:46:59
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin68827 -> 69308 bytes
-rw-r--r--app-emacs/burly/Manifest4
-rw-r--r--app-emacs/burly/burly-0.2.ebuild39
-rw-r--r--app-emacs/burly/files/50burly-gentoo.el2
-rw-r--r--app-emacs/burly/metadata.xml20
-rw-r--r--app-emacs/elpher/Manifest2
-rw-r--r--app-emacs/elpher/elpher-3.5.0.ebuild35
-rw-r--r--app-emacs/plz/Manifest4
-rw-r--r--app-emacs/plz/files/50plz-gentoo.el1
-rw-r--r--app-emacs/plz/metadata.xml20
-rw-r--r--app-emacs/plz/plz-0.5.4.ebuild38
-rw-r--r--app-emacs/ts/Manifest5
-rw-r--r--app-emacs/ts/files/50ts-gentoo.el1
-rw-r--r--app-emacs/ts/files/ts-0.3-test.patch13
-rw-r--r--app-emacs/ts/metadata.xml23
-rw-r--r--app-emacs/ts/ts-0.3.ebuild39
16 files changed, 246 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 8597373aa7b5..d961cbbd9fec 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/burly/Manifest b/app-emacs/burly/Manifest
new file mode 100644
index 000000000000..0d1fbfb7d2a7
--- /dev/null
+++ b/app-emacs/burly/Manifest
@@ -0,0 +1,4 @@
+AUX 50burly-gentoo.el 69 BLAKE2B 9ac6768efce2bab9e0b7f6830fcf2dcec59809fbe3d21566c3b4e009878f170efc1894d40110e9421abdeda7fa87fd66282673f37ffa46a6d586c4fdf160b802 SHA512 0f654e7c2e5206374e4ba9a19f38b5b38d4f358411442d716c4b5faa0da3ab1bbcc427cfa0c65c5dc334107adc8fa94e511f98ac6e19e0d0980279e5bc394a0e
+DIST burly-0.2.tar.gz 231242 BLAKE2B e50999727d654485c8265a163849f26867721f914c59b501ca8a4a42a1c12589adcd5d85b3d9ca5a383cf235962f7ca8dd8668abed1b3453b256100043875ebd SHA512 75dc26d1fae53a3ce238318e184396b2d67ce08f500c185d9fd526d6fb50c2ea3ba5a5d60789cd9b111f37336f66b1e014a19cda8bb387d6add1484cf6dd8548
+EBUILD burly-0.2.ebuild 730 BLAKE2B 754f5e6175c4a97a491e6d8a878132dbcac3512c088b2c86c7c924597db037ea11db9ebc94ff4570ca45ba4b6f794b51cba841fc4e496e1efd5c8ed3176b6a89 SHA512 9f1a796ae18588fa4cd728b3c1f49048cd221c84b3162fd5d6994ddf97763f91eb15542623a482aa2f602d397fb4f699954c8773f75e9f1038a7388e7ff8d356
+MISC metadata.xml 800 BLAKE2B 630a828d2fefd4a0cf7ef000c446e74c3b52ba7930721eda9645d555f1da49ed8fe0e98cc0121c865967c2ea2d9902bd8a34d0e7b43ba0db1a9a259d136f01b4 SHA512 8eb40db4f05ef35dae2c1f88b8c47933c4d24e1b3143d5a3b7b1131cc663b953b9bfb46f33edd6f4dbfb0da4136f2648b7aa336376bac3e8dd62d86bf470e054
diff --git a/app-emacs/burly/burly-0.2.ebuild b/app-emacs/burly/burly-0.2.ebuild
new file mode 100644
index 000000000000..787e5f49350a
--- /dev/null
+++ b/app-emacs/burly/burly-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Save and restore frames and windows with their buffers in Emacs"
+HOMEPAGE="https://github.com/alphapapa/burly.el"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/${PN}.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.info
+}
diff --git a/app-emacs/burly/files/50burly-gentoo.el b/app-emacs/burly/files/50burly-gentoo.el
new file mode 100644
index 000000000000..e19cf1e132b9
--- /dev/null
+++ b/app-emacs/burly/files/50burly-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "burly-autoloads" nil t)
diff --git a/app-emacs/burly/metadata.xml b/app-emacs/burly/metadata.xml
new file mode 100644
index 000000000000..1d53db179306
--- /dev/null
+++ b/app-emacs/burly/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This package provides tools to save and restore frame and window
+ configurations in Emacs, including buffers that may not be live anymore. In
+ this way, it’s like a lightweight "workspace" manager, allowing you to
+ easily restore one or more frames, including their windows, the windows'
+ layout, and their buffers.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/alphapapa/burly.el/issues/</bugs-to>
+ <remote-id type="github">alphapapa/burly.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/elpher/Manifest b/app-emacs/elpher/Manifest
index 0b794590c5f9..1052c1f14977 100644
--- a/app-emacs/elpher/Manifest
+++ b/app-emacs/elpher/Manifest
@@ -1,7 +1,9 @@
AUX 50elpher-gentoo.el 112 BLAKE2B 1449734aec6fd3efe344c648f815b3e826e885a7b8d57909ee0eac50a5d1937974c6dffc202147ff319f356a69f329dbdfd52cf410cc50aa3895134d8277342a SHA512 ec9eab724eaf149120eff2476f816ed1b8db6d04da1ad673cb9e55dac17dd96a2209ca842d49ef8039bf17aa4ffff940f0afd87403ab7845f9300423695eab15
DIST elpher-3.4.2.tar.gz 58546 BLAKE2B 34f0984a5533fa3049d57867214eb5000c08ca459cdaad61e08b031a1e09343697c7beaf6c83724f2b64fca85975cb27d4be16724a5a7cfb76f99c3bb048e937 SHA512 080eb9812cbcf4e72ba33272461f628892d8abc940328e6e14d56ad2a7bafb3740d75fa07b2693b9937303f9d8427531ea3aa95c228cbf53741c32cfd5408c84
DIST elpher-3.4.3.tar.gz 58909 BLAKE2B 340efe11888c737b3cc8c7b428d302542030236b61cd0f86cce56e289203ea61ed8cb0a5da24e334ff8621bf3a679828ef8053d234410375484ddd3b63928b39 SHA512 53a9bf80df7c66c7f7453a60daf1c08f88228d03954bb638e703ac516001625be134ae530dd078ebe646ad922593b9ffa20daf325b23d299c65329216bbab4b2
+DIST elpher-3.5.0.tar.gz 59890 BLAKE2B 403597de5181377dae8527d2df4b547a7bf1ed5499c10501b3c057575789a685cc454118b136ca3c3c172626aa686bf99c60f365365f29fef68091816d9f2a32 SHA512 464f9dab3a99e07222c36ab2831d39e7eb90d79892d6cf53386b7b0e22f9da7b8f96a88c87e76dd722ff6849ca4cec75293ebd9c142920e859ea0be9ccf371e8
EBUILD elpher-3.4.2.ebuild 776 BLAKE2B aa6bec2947fca7ac86ba841b08a1e7fee7339a7015ab5de630fb8ef19539ba05c3e8a01c730045c40c01d982a9c0606bc8b402bd168ed83e10a7cd4651e1e42c SHA512 bf0dae5944e233bdfda1066516fe4000dcd32cdf453d615a137d7333aa05c1c8b3606ed8ce20c53bcf2771079a8c8b1755977dd1551e7a728b5d7e4f59274d95
EBUILD elpher-3.4.3.ebuild 776 BLAKE2B 7f0b69dab1d19e0236d0a4399b18f747c8ab530e81103eaca3ece9f6a2befca807ef1c86a4a0c0c2e08f6a54673849cce8ade355e23cf44c05636d9157b9c551 SHA512 656c99e18a9434631bdf3c23ffe764f163cd2fa72b532c8c2d85661136f8301288d97b6d4398573e63af1f6ffca492986470b3e23aa2dc93d3a05e15513c9256
+EBUILD elpher-3.5.0.ebuild 778 BLAKE2B 3e33ce7ff41bd96ad741bd742357091774eaed2c00d35a281df0ba744a6f299de7d10a037c699a79f0934ad2d6bcbaf975eabc62af61657d27f4e2426a902aa8 SHA512 90902a5b64aa95cd0d037fbee71c343b5715af8e85602510be7ef96af762d28dd18d71dca49b8ad39d5c1b376d167d465d87670661007d4aab467872f699ef45
EBUILD elpher-9999.ebuild 776 BLAKE2B aa6bec2947fca7ac86ba841b08a1e7fee7339a7015ab5de630fb8ef19539ba05c3e8a01c730045c40c01d982a9c0606bc8b402bd168ed83e10a7cd4651e1e42c SHA512 bf0dae5944e233bdfda1066516fe4000dcd32cdf453d615a137d7333aa05c1c8b3606ed8ce20c53bcf2771079a8c8b1755977dd1551e7a728b5d7e4f59274d95
MISC metadata.xml 269 BLAKE2B e431fc3cbf82ae368f62ce9c0a0779eef2141b1d6aef94a47a87d29c92f5fae3f9cbcfbe59ab14a74bee673698b61a7446e4ade1804f330a9e2926b43ad3e700 SHA512 2899510a1184404b72d35aea6d963bfe2be26922150cd2f1f68107c22055a12e5b9ac54d9c07ad539ddaa204624ddf61990a3272ef4aa3f31e10b0a78b2fcc9a
diff --git a/app-emacs/elpher/elpher-3.5.0.ebuild b/app-emacs/elpher/elpher-3.5.0.ebuild
new file mode 100644
index 000000000000..1b222a7660d0
--- /dev/null
+++ b/app-emacs/elpher/elpher-3.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Practical and friendly Gopher and Gemini client for GNU Emacs"
+HOMEPAGE="https://thelambdalab.xyz/elpher/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://thelambdalab.xyz/${PN}.git"
+else
+ if [[ ${PV} == 3.5.0 ]] ; then
+ COMMIT=81f2883
+ SRC_URI="https://thelambdalab.xyz/gitweb/index.cgi?p=${PN}.git;a=snapshot;h=${COMMIT};sf=tgz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ die "could not generate SRC_URI"
+ fi
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+ELISP_REMOVE="elpher-pkg.el"
+
+DOCS=( ISSUES.org README )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/plz/Manifest b/app-emacs/plz/Manifest
new file mode 100644
index 000000000000..bd082e2ef771
--- /dev/null
+++ b/app-emacs/plz/Manifest
@@ -0,0 +1,4 @@
+AUX 50plz-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST plz-0.5.4.tar.gz 101382 BLAKE2B cba7089ed3f6c6d616d6d8b506e9779c1fdc56b8c048010cb2e61f03d83669aa3475314936c9fc4b02d473484268a303495605e785840644bc3b9b92f50be090 SHA512 3a64a49efcf32191099abcd5dd5955b02ce3afa98ec3ecd79d4bfaadf52bc4a5602fda3aca4482e77e465e5d071400ae8200cf900e4f0ed931e93e1458303fa1
+EBUILD plz-0.5.4.ebuild 771 BLAKE2B f005a9daeea1c89120de92bbbc29267fafaf75c608b15aa6b4909aa92ec844e843946cceda38ed5d27b35c3236db7a72ad932b14039e0ffb38e5290d0fc3192a SHA512 7502192929cf47da9ff120c650f9183bfcd52bb2281e3eba02c06a71776393d355a9f2f1bbb18139ca70dac5b563d3c56c82c3c659a4f0762438bc375555fafa
+MISC metadata.xml 826 BLAKE2B 2c26aa08682b905ec5f450f20a4b77b2ee2108f172deeda1bb95ddb80d1a6d53a76b091350126171c2b9dfda6161ba61958bbbf53fa94f4dd883b1eccd9f6125 SHA512 b48b5766222e784021656410b1467bbcab2646133d3a4af58601ace46ff68ee87df2a156329b19b72b1f42f77ad8f00c2fceca1210f8aca0db864ed044ffb0d6
diff --git a/app-emacs/plz/files/50plz-gentoo.el b/app-emacs/plz/files/50plz-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/plz/files/50plz-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/plz/metadata.xml b/app-emacs/plz/metadata.xml
new file mode 100644
index 000000000000..312ec018bd3c
--- /dev/null
+++ b/app-emacs/plz/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ plz is an HTTP library for Emacs. It uses curl as a backend, which avoids
+ some of the issues with using Emacs's built-in url library. It supports
+ both synchronous and asynchronous requests. Its API is intended to be
+ simple, natural, and expressive. Its code is intended to be simple and
+ well-organized. Every feature is tested against httpbin.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/alphapapa/plz.el/issues/</bugs-to>
+ <remote-id type="github">alphapapa/plz.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/plz/plz-0.5.4.ebuild b/app-emacs/plz/plz-0.5.4.ebuild
new file mode 100644
index 000000000000..fc3776f2a6fa
--- /dev/null
+++ b/app-emacs/plz/plz-0.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="HTTP library with curl backend for GNU Emacs"
+HOMEPAGE="https://github.com/alphapapa/plz.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/plz.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/plz.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/plz.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="net-misc/curl"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests -l tests/test-plz.el
+
+src_install() {
+ elisp_src_install
+
+ doinfo plz.info
+}
diff --git a/app-emacs/ts/Manifest b/app-emacs/ts/Manifest
new file mode 100644
index 000000000000..4bfe3a5ca106
--- /dev/null
+++ b/app-emacs/ts/Manifest
@@ -0,0 +1,5 @@
+AUX 50ts-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+AUX ts-0.3-test.patch 650 BLAKE2B 174a01b8035a677e2ae742931ac9b9d9f7eadd9a0bd02ffda69867c950239c32e948b952d6a16ffcd4ea423b84b8eec4d20a8000bddc4ef64e072e29fccfa203 SHA512 0276582170693f476c448dc6154b4930a52734ddf8325a903b018f3aca8e7d16ba150d1ef50f61e541ed234b2097c2b9f7d048f74cf058a6c088070c3722e2de
+DIST ts-0.3.tar.gz 50790 BLAKE2B 99708218584764776d6f93565b7da83e266a1ea2588aba614151a9cffaddd69983a0dd897b9a59247e73992b1611dc761f250f189e179d72c36dc417f5f60aa2 SHA512 8e31543ffb69214c2daf3a26b8f2a76c9933e13f699575678c3262b1524da6615d34ec3fe9d30c62c354ba7139e7a96ac5a894850569688e75ba64959bded61c
+EBUILD ts-0.3.ebuild 855 BLAKE2B 75054d6ba86495a1bad1c8badb0a73e0e51c6043dc16afc4168920c9292fcbf7dc42432da4ae56674fcb41b2d25bf784f80d3ff8c5e824aa60765538d17f3b25 SHA512 d9551b5b1ada56b9581bcacaa85b9458e0dc27988f970d6f08c9c51a3b664ebe6bba798e7c54261f1f69568ad0bc3f6159bf4a088d978879febda7ee2f45b7f5
+MISC metadata.xml 1017 BLAKE2B bd37ba7901c48fef2cbfd665f2785a83b4bb2a3c0ff96177f7e6e4248efbc4698347fbce7f14e1ef6f77de3d4d9b0d267bcbef5d1a396f1dfd82a634b2c6ddee SHA512 a3b39642f71c692f2e68e96b96dbe2cf25cb014734c0ade0026a839eb15a2265d69203e76b3c707763f7710de9f93b3df822e1ca141d5ce86c8c3056f8ad5a9b
diff --git a/app-emacs/ts/files/50ts-gentoo.el b/app-emacs/ts/files/50ts-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/ts/files/50ts-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/ts/files/ts-0.3-test.patch b/app-emacs/ts/files/ts-0.3-test.patch
new file mode 100644
index 000000000000..0b473d24873f
--- /dev/null
+++ b/app-emacs/ts/files/ts-0.3-test.patch
@@ -0,0 +1,13 @@
+--- a/test/test.el
++++ b/test/test.el
+@@ -259,10 +259,8 @@
+ ;; machine's local timezone affecting results.
+ (let ((ts (make-ts :year 2019 :month 7 :day 27 :hour 20 :minute 48 :second 08 :tz-offset "-0400")))
+ ;; Following the pattern in the function:
+- (should (equal (ts-format ts) "2019-07-27 20:48:08 -0400"))
+ (should (equal (ts-format "%Y" ts) "2019"))
+ (should (ts-format "%Y"))
+- (should (equal (ts-format nil ts) "2019-07-27 20:48:08 -0400"))
+ (should (ts-format)))
+ (let ((ts (make-ts :year 2019 :month 7 :day 27 :hour 19 :minute 48 :second 08 :tz-offset "-0500")))
+ ;; Following the pattern in the function:
diff --git a/app-emacs/ts/metadata.xml b/app-emacs/ts/metadata.xml
new file mode 100644
index 000000000000..83412a187471
--- /dev/null
+++ b/app-emacs/ts/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ ts is a date and time library for Emacs. It aims to be more convenient than
+ patterns like (string-to-number (format-time-string "%Y")) by providing
+ easy accessors, like (ts-year (ts-now)). To improve performance
+ (significantly), formatted date parts are computed lazily rather than when
+ a timestamp object is instantiated, and the computed parts are then cached
+ for later access without recomputing. Behind the scenes, this avoids
+ unnecessary (string-to-number (format-time-string... calls, which are
+ surprisingly expensive.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/alphapapa/ts.el/issues/</bugs-to>
+ <remote-id type="github">alphapapa/ts.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/ts/ts-0.3.ebuild b/app-emacs/ts/ts-0.3.ebuild
new file mode 100644
index 000000000000..4f61deb30b25
--- /dev/null
+++ b/app-emacs/ts/ts-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs timestamp and date-time library"
+HOMEPAGE="https://github.com/alphapapa/ts.el"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/ts.el.git"
+else
+ [[ ${PV} == 0.3 ]] && COMMIT=552936017cfdec89f7fc20c254ae6b37c3f22c5b
+ SRC_URI="https://github.com/alphapapa/ts.el/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/ts.el-${COMMIT}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/dash
+ app-emacs/s
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/ts-0.3-test.patch )
+
+DOCS=( README.org notes.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ LANG=C TZ=/usr/share/zoneinfo/America/Chicago \
+ elisp-test-ert test -l test/test.el
+}