summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 00:00:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 00:00:11 +0000
commitca7fcaa76aaf1f94284894a8d9a01bb153e80b11 (patch)
treedcfb443cd20285c353c22c05f43f96ca3d3161a8 /app-emacs
parent150a86a9cb006b4800d6517d58532b8a556fec1e (diff)
gentoo auto-resync : 20:01:2023 - 00:00:11
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin65495 -> 65823 bytes
-rw-r--r--app-emacs/doom-modeline/Manifest4
-rw-r--r--app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild41
-rw-r--r--app-emacs/doom-modeline/files/50doom-modeline-gentoo.el2
-rw-r--r--app-emacs/doom-modeline/metadata.xml13
-rw-r--r--app-emacs/shrink-path/Manifest4
-rw-r--r--app-emacs/shrink-path/files/50shrink-path-gentoo.el1
-rw-r--r--app-emacs/shrink-path/metadata.xml13
-rw-r--r--app-emacs/shrink-path/shrink-path-0.3.1.ebuild43
9 files changed, 121 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 8c311ee5d996..036927fc069a 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/doom-modeline/Manifest b/app-emacs/doom-modeline/Manifest
new file mode 100644
index 000000000000..cff61bee753e
--- /dev/null
+++ b/app-emacs/doom-modeline/Manifest
@@ -0,0 +1,4 @@
+AUX 50doom-modeline-gentoo.el 77 BLAKE2B 0b7e10cff2a5e20083f8ba376e3e72ea1fc423cb8fa605b59cfc601aac72fe8611a6b558924c52b1f74ef2413d2efea806c929fa1d4b8b212cabbb9ef62d730f SHA512 6dc0e3ec4c48923a850466c86b97a63472e0861dcd8bfc8d346cac17e3cf1f0aa03fe0c3d9b75efaa73ec919073024320d3b4cfc17e8c1a2c0b2a17a43c72339
+DIST doom-modeline-3.3.2.tar.gz 61363 BLAKE2B 2b80748265f911954e1726dc30e6bacf4ba7ffb6eb589e8f67c366b818e212376039eb025d380937b327f7d3d4a980ec6bfe0589ac38af1e0d678a8f6038b97f SHA512 ff0b41c5f8dc7e5a4a5bccaa710b445a1894948893cd7dea6c564d3a9b1be5cd7cd005e6a28613a6800526d5158faebfef51d21b9e911d97416821210954f0b3
+EBUILD doom-modeline-3.3.2.ebuild 923 BLAKE2B ab5471a1068cb164c95e846ecd78c1e63156c2205bd2a3a331e86f4c752a71c3f4c7439a1f637ec9bf1ff7bf2d6d0138629013f416bcd40ee51ab0ccb477aa5c SHA512 1b412ecc2f06a0871ecbbbeddb3ab379d782d1a8eb278c606d1a00d8504c500816086fa538f6e9b107ff4b579e7a6176828d1b3cb7ad47ecc90c5c41e72cbf60
+MISC metadata.xml 437 BLAKE2B 4510e1869b8871d0c054ec00c7c639125d52f451ffc129fe5a8255026ddd3c2fe36d8e9f5ef9a47c7f0b87b356d67e16cc2ab84b6414b7399b402df3fb0d3d89 SHA512 cda6737b5873ec737482048c543f9a5e8a8137d13072d663c8b714e0607c47c8d77ffdef9a2d9c8713c0c321c0e7bd3cd1531546f53c045000853badd575e61e
diff --git a/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild b/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild
new file mode 100644
index 000000000000..8699aa390639
--- /dev/null
+++ b/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Fancy and fast mode-line for Emacs inspired by minimalism design"
+HOMEPAGE="https://seagle0128.github.io/doom-modeline/
+ https://github.com/seagle0128/doom-modeline/"
+SRC_URI="https://github.com/seagle0128/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ app-emacs/all-the-icons
+ app-emacs/compat
+ app-emacs/shrink-path
+"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -L . -L test \
+ -l test/${PN}-core-test.el \
+ -l test/${PN}-env-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
diff --git a/app-emacs/doom-modeline/files/50doom-modeline-gentoo.el b/app-emacs/doom-modeline/files/50doom-modeline-gentoo.el
new file mode 100644
index 000000000000..0dd9efab6129
--- /dev/null
+++ b/app-emacs/doom-modeline/files/50doom-modeline-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "doom-modeline-autoloads" nil t)
diff --git a/app-emacs/doom-modeline/metadata.xml b/app-emacs/doom-modeline/metadata.xml
new file mode 100644
index 000000000000..e8b3def7a3b9
--- /dev/null
+++ b/app-emacs/doom-modeline/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/seagle0128/doom-modeline/issues/</bugs-to>
+ <remote-id type="github">seagle0128/doom-modeline</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/shrink-path/Manifest b/app-emacs/shrink-path/Manifest
new file mode 100644
index 000000000000..8a0b49ec2303
--- /dev/null
+++ b/app-emacs/shrink-path/Manifest
@@ -0,0 +1,4 @@
+AUX 50shrink-path-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST shrink-path.el-v0.3.1.tar.bz2 15743 BLAKE2B 8f5db089737f2d31c9f5852265f1b33679de3cc72989bf04b8d50871b3b8fa356da6823177759561b99ee5b032fb10ba1c51f49cdd7d74daafb1d6cac44ba2b7 SHA512 f4cc191186c2a2e706ff08fbcd43f24dd67297a368c42da72626d70e3522d5b24ceba45a2e17821f6288576f10e0208e3d643946108edd6180502dd1bad019ed
+EBUILD shrink-path-0.3.1.ebuild 822 BLAKE2B b39980b10b7f3961a114896066592ff7d6961188222c323a3a94d48f883cb60d44a4679b5d187496fb64b7a62acd73a6a578379db7d34658086219b0d180ab23 SHA512 fe1f8cac2082b6ed5afc051771860d0959be9e9a4289f5813b76f21e9a68db70c646e5fe6e8e187063c23b8dda65c2a84816c2a14860ea62950d1b728e94769c
+MISC metadata.xml 433 BLAKE2B eaf63f4513651f57d6e4a5032a2f244011234c6fd995939ed294ed8ceefc75487664cd769ed64eaf82b6040bbddecfb4f85ffc907a5103febf53cb605afd9a40 SHA512 65fcabbc6edff9aa6580630195a5ed911046fce5b61371881ccc4c7f19645c592f236a2ea06bd07469c3b47034e3639d0b4e450d4660a3eac0f7cf6750fee317
diff --git a/app-emacs/shrink-path/files/50shrink-path-gentoo.el b/app-emacs/shrink-path/files/50shrink-path-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/shrink-path/files/50shrink-path-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/shrink-path/metadata.xml b/app-emacs/shrink-path/metadata.xml
new file mode 100644
index 000000000000..b46545666722
--- /dev/null
+++ b/app-emacs/shrink-path/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/bennya/shrink-path.el/-/issues/</bugs-to>
+ <remote-id type="gitlab">bennya/shrink-path.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/shrink-path/shrink-path-0.3.1.ebuild b/app-emacs/shrink-path/shrink-path-0.3.1.ebuild
new file mode 100644
index 000000000000..b68e36a0c793
--- /dev/null
+++ b/app-emacs/shrink-path/shrink-path-0.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Fish-style path truncation for GNU Emacs"
+HOMEPAGE="https://gitlab.com/bennya/shrink-path.el/"
+SRC_URI="https://gitlab.com/bennya/${PN}.el/-/archive/v${PV}/${PN}.el-v${PV}.tar.bz2"
+S="${WORKDIR}"/${PN}.el-v${PV}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/s
+ app-emacs/dash
+ app-emacs/f
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/buttercup )
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i 's|it "same as shrink-path"|xit "same as shrink-path"|' \
+ "${S}"/test/shrink-path-test.el || die
+
+ default
+}
+
+src_test() {
+ buttercup -L . -L test --traceback full test || die
+}