summaryrefslogtreecommitdiff
path: root/app-emulation/buildah
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /app-emulation/buildah
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'app-emulation/buildah')
-rw-r--r--app-emulation/buildah/Manifest2
-rw-r--r--app-emulation/buildah/buildah-1.11.5.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
index 0325ff2fca53..43694cdc65af 100644
--- a/app-emulation/buildah/Manifest
+++ b/app-emulation/buildah/Manifest
@@ -1,5 +1,7 @@
DIST buildah-1.11.2.tar.gz 10128075 BLAKE2B ad8f4253b62cd7709bf5ae530d002190c1850da6bbfa7dff2281de0592422eccc67a4ba6e52f7a82d6c1b320b986237a84d0ffaaf9b3b1b93822a54621365250 SHA512 f491d96d5bb4d0aa03981fb58d24f36c2e3928179c8fb79e85f323ce9a65ae6da05b816d86ae43f94a83a1b2445b315f93ca28b531436d9b4e5861e4adef2aac
DIST buildah-1.11.3.tar.gz 10429884 BLAKE2B 2d433a128d115c6b2f3a9d246d41406993905dee357237796cea3295036d026ca93f8c98ca992cfebfa574ab0d5e7b974fd356a146b7cde58986166bc18a5645 SHA512 07fff3f8c044ad01a663bf5470b19f75568ce741b3bb45f656200099ba559622597111ede3e20331dc06139f2e58d962d92bf0fdd00284ca6ed05b5b66500975
+DIST buildah-1.11.5.tar.gz 10594213 BLAKE2B 421d4ea78ad84fbae42086b8d49fec26db8e2aa1f83e261a8b5b1f3f41a5be4ea2fdeb41d4e27fb52bf23f309b8aea1d050cea0c6deffcad0ebb273032e712ba SHA512 04a9c51e1cb6f3a88f118b69dcea1eba85b02d534e671cd5bf31a6d6a797bce4a488c9373c92736fccd74331c1242ff60a95f44626ecbb50c32db176c7106e86
EBUILD buildah-1.11.2.ebuild 1485 BLAKE2B 4f766ba24804b36bc976d4e1f767e469482ab8d9930b8a5488a57cd72b3644ca7bafe8d909d6e7272d73c99daf905a589bcb8b9032aeda9869e7d0bbd8ef1943 SHA512 7b10c0998a118d0e888222fe2bee26dcb2887b1f965a114f14a823b1ea8d917d55e6af657f68e003b779642f6205de43d72c4a3f119ebe8e5594a00241d3e858
EBUILD buildah-1.11.3.ebuild 1485 BLAKE2B 01285630eb57227136150c22ff37c364786541b891c0141614e5c08a19403257ec0f2e0c7947a011c9c72d066d0581ea46a09e8cd4714bcde069a78f990efec5 SHA512 0af5f84ecf95ae34df0ed7617cb7459f9f679021e388b7247bba13a16e18649f3a0ad1cd16deca6cd3b03aa40f3ef63884bce790ca7dd25c1c2222040806cf01
+EBUILD buildah-1.11.5.ebuild 1208 BLAKE2B eda40fe5008c05f0de349186a5701bb0759bbcf38f82cbdc7c4a5dc57b4e5d3fa9528683493d8e4786d5e981a8701510a4e2e21d178316433765c0f387a381d7 SHA512 bccc1c143aeec3b623709bca126072fa8cf0043e0dd85652527379f563b1c11283a5aed2d78c8899d3cf40900eb881069977884a5fa8ab7e0a3c5b5737a9dbf9
MISC metadata.xml 430 BLAKE2B 7486f6f62edf735da40a63ee17411e421101908e3e2652584800a3bfe315afbd46b9b6fe6338f8bb6cc7d09eb1bab34c1600e9aa6ae08b8d0326ee896270f2ea SHA512 8f25eca02d11272cc5a479adf3e361fe7f7cd595b0d54d26668b68940e012499d6c447ba93f44773a72f5431dffc346f1286be1f1a984eaa94e9dfc9501eb7b0
diff --git a/app-emulation/buildah/buildah-1.11.5.ebuild b/app-emulation/buildah/buildah-1.11.5.ebuild
new file mode 100644
index 000000000000..2f7bb8f8c0d9
--- /dev/null
+++ b/app-emulation/buildah/buildah-1.11.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+
+KEYWORDS="~amd64"
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="selinux"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="7c97335"
+SRC_URI="https://github.com/containers/buildah/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RDEPEND="app-crypt/gpgme:=
+ app-emulation/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -e 's|^\(GIT_COMMIT ?= \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
+
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+}
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME
+ emake all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin ${PN} imgtype
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}